summaryrefslogtreecommitdiff
path: root/app-i18n/xsunpinyin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /app-i18n/xsunpinyin
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'app-i18n/xsunpinyin')
-rw-r--r--app-i18n/xsunpinyin/Manifest2
-rw-r--r--app-i18n/xsunpinyin/xsunpinyin-2.0.4_pre20200306162733.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/app-i18n/xsunpinyin/Manifest b/app-i18n/xsunpinyin/Manifest
index 7a715785d9a0..16284575cfc8 100644
--- a/app-i18n/xsunpinyin/Manifest
+++ b/app-i18n/xsunpinyin/Manifest
@@ -1,3 +1,5 @@
+DIST sunpinyin-2.0.4_pre20200306162733.tar.gz 547519 BLAKE2B 6e0e4457217d7b85221cab15173f588a5c7c039208a8f6cd48ed5fb21c5b5eae2f4616d6fddbf6eff8a006193097de26c866d5385d4602f41059ee8d7e52a2d5 SHA512 e8cf73aeca8dcbc7dd6f51f034a9a0363201bc14a814800e071c987933935b0e8039aa84178a6bd1cba1c7dee4b25b2d5546e78ea683e68e8981afea48fdab33
DIST sunpinyin-3.0.0_rc1.tar.gz 547138 BLAKE2B 682e733241d690d1fef8ce452c497a894c5ab61bf5298c1f292ce3a25a681d594744db43ebd51b3e59274cce0e47a1bce15a793f2c20e2998915c3432f2a7c32 SHA512 c9d4936de5835a7f02e52c5b32bf1a42d76bf7588449aaa813f3df7ab2d72f3ca0f4e18f74a60be4860f0724b5e05cbe567c67e6f3150b0e71b23b3a9002fc5e
+EBUILD xsunpinyin-2.0.4_pre20200306162733.ebuild 1822 BLAKE2B 29544096b09a537a7ff42ffb1018748b80189877c785837a9bbc8e06e4c3b12e2460e5f71baaf900de2a68b7cac83b63214fcf96769125bc677ddd942e859bb7 SHA512 a60ba52e47fc68e71b3dc3e5d719fc6237c152a9454a127287830ae8df5f8be4c8fb28450775887a0cd634648dd2cac82a9783d82007c19aae4afb89ac4a804c
EBUILD xsunpinyin-3.0.0_rc1.ebuild 838 BLAKE2B da1adbb00714726eedd65cd1ccfe144ed469265dce54afb0e64ba2f8ffe72cab2eaa6f99a44375164d28fbabe2315296318a1c8916aff579ecb53d7b48542a37 SHA512 f44f42d1a03aa89d9c2ab128f4a8d40823546029a053910f1b5b28ad3a48a9b951ea83bb15f6301a361ad0c0efa72b83d8f855d2fced666d5588d6fa0f330cf4
MISC metadata.xml 318 BLAKE2B cd239258d08a95f0d27a760678be36731954a721daae521d147b882fd07eb5206a38ce9ac9938e94e3501611cd95aba5699fb2e5a5176f3652e8e5531e5e4cf8 SHA512 44d76425ce41ba6cb84f584c7dfe3b0552eb65aec93b4ed72f9c2e6c153e5e51a3965bf4248486046d3ca9e39f861c3bcde90424ba35e4a57f2102a24faf0df5
diff --git a/app-i18n/xsunpinyin/xsunpinyin-2.0.4_pre20200306162733.ebuild b/app-i18n/xsunpinyin/xsunpinyin-2.0.4_pre20200306162733.ebuild
new file mode 100644
index 000000000000..410b23009438
--- /dev/null
+++ b/app-i18n/xsunpinyin/xsunpinyin-2.0.4_pre20200306162733.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2011-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=(python{3_6,3_7,3_8})
+
+inherit python-any-r1 scons-utils toolchain-funcs
+
+MY_PN="sunpinyin"
+MY_P="${MY_PN}-${PV}"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/sunpinyin/sunpinyin"
+elif [[ "${PV}" == *_pre* ]]; then
+ SUNPINYIN_GIT_REVISION="f39c195db08661e894017507842991a1ef70bedf"
+fi
+
+DESCRIPTION="Standalone XIM server for SunPinyin"
+HOMEPAGE="https://github.com/sunpinyin/sunpinyin"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+elif [[ "${PV}" == *_pre* ]]; then
+ SRC_URI="https://github.com/sunpinyin/${MY_PN}/archive/${SUNPINYIN_GIT_REVISION}.tar.gz -> ${MY_P}.tar.gz"
+else
+ SRC_URI="https://github.com/sunpinyin/${MY_PN}/archive/v${PV/_/-}.tar.gz -> ${MY_P}.tar.gz"
+fi
+
+LICENSE="|| ( CDDL LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="~app-i18n/sunpinyin-${PV}
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango"
+RDEPEND="${DEPEND}
+ app-i18n/sunpinyin-data"
+
+if [[ "${PV}" == *_pre* ]]; then
+ S="${WORKDIR}/${MY_PN}-${SUNPINYIN_GIT_REVISION}"
+elif [[ "${PV}" != "9999" ]]; then
+ S="${WORKDIR}/${MY_PN}-${PV/_/-}"
+fi
+
+src_prepare() {
+ default
+
+ # https://github.com/sunpinyin/sunpinyin/pull/101
+ sed -e "/^[[:space:]]*print /s/print \(.*\)/print(\1)/" -i wrapper/xim/SConstruct || die
+
+ # https://github.com/sunpinyin/sunpinyin/issues/110
+ sed -e "s/^\( *\)('CXX', 'CXX'),/&\n\1('AR', 'AR'),\n\1('RANLIB', 'RANLIB'),/" -i wrapper/xim/SConstruct || die
+}
+
+src_configure() {
+ tc-export AR CC CXX RANLIB
+}
+
+src_compile() {
+ escons -C wrapper/xim \
+ --prefix="${EPREFIX}/usr"
+}
+
+src_install() {
+ escons -C wrapper/xim --install-sandbox="${D}" install
+}