summaryrefslogtreecommitdiff
path: root/app-laptop/pommed/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-laptop/pommed/files
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-laptop/pommed/files')
-rw-r--r--app-laptop/pommed/files/pommed-1.39.patch89
-rw-r--r--app-laptop/pommed/files/pommed.rc19
-rw-r--r--app-laptop/pommed/files/pommed.service10
3 files changed, 0 insertions, 118 deletions
diff --git a/app-laptop/pommed/files/pommed-1.39.patch b/app-laptop/pommed/files/pommed-1.39.patch
deleted file mode 100644
index 1215606c35cb..000000000000
--- a/app-laptop/pommed/files/pommed-1.39.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-diff --git a/gpomme/Makefile b/gpomme/Makefile
-index 0874b48..a3ab64a 100644
---- a/gpomme/Makefile
-+++ b/gpomme/Makefile
-@@ -1,5 +1,3 @@
--CC = gcc
--
- GTK_CFLAGS = $(shell pkg-config --cflags gtk+-2.0)
- GTK_LIBS = $(shell pkg-config --libs gtk+-2.0)
-
-@@ -14,7 +12,7 @@ CONFUSE_LIBS = $(shell pkg-config libconfuse --libs)
-
- INOTIFY_CFLAGS = $(shell test -e /usr/include/sys/inotify.h || echo -DNO_SYS_INOTIFY_H)
-
--CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(DBUSGLIB_CFLAGS) $(GTK_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS)
-+CFLAGS += -Wall $(DBUS_CFLAGS) $(DBUSGLIB_CFLAGS) $(GTK_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS)
- LDLIBS = -lpthread -lX11 $(DBUS_LIBS) $(DBUSGLIB_LIBS) $(GTK_LIBS) $(CONFUSE_LIBS)
-
- SOURCES = gpomme.c theme.c conffile.c \
-@@ -30,6 +28,7 @@ all: gpomme mo
- mo: $(MOFILES)
-
- gpomme: $(OBJS)
-+ ${CC} -o $@ ${OBJS} ${LDLIBS} ${LDFLAGS}
-
- gpomme.o: gpomme.c gpomme.h theme.h ../client-common/dbus-client.h ../client-common/video-client.h
-
-diff --git a/pommed/Makefile b/pommed/Makefile
-index 5f3cbf9..3425a2a 100644
---- a/pommed/Makefile
-+++ b/pommed/Makefile
-@@ -1,7 +1,5 @@
- ARCH ?= $(shell uname -m)
-
--CC = gcc
--
- DBUS_CFLAGS = $(shell pkg-config dbus-1 --cflags) -DDBUS_API_SUBJECT_TO_CHANGE
- DBUS_LIBS = $(shell pkg-config dbus-1 --libs)
-
-@@ -18,7 +16,7 @@ INOTIFY_CFLAGS = $(shell test -e /usr/include/sys/inotify.h || echo -DNO_SYS_INO
-
- TIMERFD_CFLAGS = $(shell test -e /usr/include/sys/timerfd.h || echo -DNO_SYS_TIMERFD_H)
-
--CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(ALSA_CFLAGS) $(AUDIOFILE_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS) $(TIMERFD_CFLAGS)
-+CFLAGS += -Wall $(DBUS_CFLAGS) $(ALSA_CFLAGS) $(AUDIOFILE_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS) $(TIMERFD_CFLAGS)
-
- LDLIBS = -pthread -lrt $(DBUS_LIBS) $(ALSA_LIBS) $(AUDIOFILE_LIBS) $(CONFUSE_LIBS)
-
-@@ -54,6 +52,7 @@ ifeq ($(LIBPCI_SHARED), true)
-
- CFLAGS += $(LIBPCI_CFLAGS)
- LDLIBS += $(LIBPCI_LIBS)
-+ LIBS = $(LIBPCI_LIBS)
- else
- LIB_OBJS += /usr/lib/libpci.a
- LDLIBS += -lz
-@@ -73,6 +72,7 @@ OBJS = $(SOURCES:%.c=%.o)
-
-
- pommed: $(OBJS) $(LIB_OBJS)
-+ ${CC} -o $@ ${OBJS} ${LDLIBS} ${LDFLAGS}
-
- pommed.o: pommed.c pommed.h evloop.h kbd_backlight.h lcd_backlight.h cd_eject.h evdev.h conffile.h audio.h dbus.h beep.h
-
-diff --git a/wmpomme/Makefile b/wmpomme/Makefile
-index cc7a438..6c4bee1 100644
---- a/wmpomme/Makefile
-+++ b/wmpomme/Makefile
-@@ -1,11 +1,9 @@
--CC = gcc
--
- DBUS_CFLAGS = $(shell pkg-config dbus-1 --cflags) -DDBUS_API_SUBJECT_TO_CHANGE
- DBUS_LIBS = $(shell pkg-config dbus-1 --libs)
-
- TIMERFD_CFLAGS = $(shell test -e /usr/include/sys/timerfd.h || echo -DNO_SYS_TIMERFD_H)
-
--CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(TIMERFD_CFLAGS)
-+CFLAGS += -Wall $(DBUS_CFLAGS) $(TIMERFD_CFLAGS)
- LDLIBS = -lrt -lXpm -lXext -lX11 $(DBUS_LIBS)
-
- SOURCES = wmgeneral.c wmpomme.c \
-@@ -15,6 +13,7 @@ SOURCES = wmgeneral.c wmpomme.c \
- OBJS = $(SOURCES:%.c=%.o)
-
- wmpomme: $(OBJS)
-+ ${CC} -o $@ ${OBJS} ${LDLIBS} ${LDFLAGS}
-
- wmpomme.o: wmpomme.c wmgeneral.h wmpomme-master.xpm ../client-common/dbus-client.h
-
diff --git a/app-laptop/pommed/files/pommed.rc b/app-laptop/pommed/files/pommed.rc
deleted file mode 100644
index 23904fc7d3a0..000000000000
--- a/app-laptop/pommed/files/pommed.rc
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need dbus alsasound
-}
-
-start() {
- ebegin "Running pommed daemon"
- start-stop-daemon --start --quiet --exec /usr/bin/pommed
- eend $?
-}
-
-stop() {
- ebegin "Stopping pommed daemon"
- start-stop-daemon --stop --pidfile /var/run/pommed.pid
- eend $?
-}
diff --git a/app-laptop/pommed/files/pommed.service b/app-laptop/pommed/files/pommed.service
deleted file mode 100644
index 8407c1db9550..000000000000
--- a/app-laptop/pommed/files/pommed.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=MacBook Hotkey Event Handler
-
-[Service]
-Type=dbus
-BusName=org.pommed
-ExecStart=/usr/bin/pommed -f
-
-[Install]
-WantedBy=multi-user.target