summaryrefslogtreecommitdiff
path: root/app-laptop/thinkfan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-laptop/thinkfan
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-laptop/thinkfan')
-rw-r--r--app-laptop/thinkfan/Manifest3
-rw-r--r--app-laptop/thinkfan/metadata.xml14
-rw-r--r--app-laptop/thinkfan/thinkfan-0.9.3.ebuild50
3 files changed, 67 insertions, 0 deletions
diff --git a/app-laptop/thinkfan/Manifest b/app-laptop/thinkfan/Manifest
new file mode 100644
index 000000000000..3878b64edae0
--- /dev/null
+++ b/app-laptop/thinkfan/Manifest
@@ -0,0 +1,3 @@
+DIST thinkfan-0.9.3.tar.gz 39527 BLAKE2B e6a6d09493d94b4de9ada20dcc4b0251c5f2c148f7faa7f69c04fe2a279a9cfe253a0ea1a01fe94ed108e8731e2ba01edef5df10dfb887ea961a356dff733854 SHA512 d2a29f9cae636c22b66958f8ec50cb60a162d745c3967257bb5e20cc9e152894d4e8a66f897ffa4e49353eba4a42e3499bb9e554719974284089a46cfc6280d7
+EBUILD thinkfan-0.9.3.ebuild 1069 BLAKE2B 0e4862e477f197efc30f9c72330e8153327325a733277220a0e65725483762e700515dc3204712d8f6af2b06c576cf17f114683993c0385383cc92c58e211318 SHA512 ffec534bfe1c1eb08c1de3858347781d6f0dc349d7f3de39196a47166e65142d649e0e889141e9c90ce193f0f984ac386ce39cc45f6e70ff971278c3b6560247
+MISC metadata.xml 419 BLAKE2B 614fa01aed150fe8dd815d2efa970e0a78de6652c114a3c5236dbd00cb794fc283f5360bc1d9e79a02fa9866a817785f362aba5908ea08864820a89ba526c2ea SHA512 c0979a5886be1a527d7eb45176316320b6c116181f83ade62c6b900a01e6fb6538d738eb081e99dc6f3fd03589e34ac45f5c5da8eebbd33f13d04baa7fd913c8
diff --git a/app-laptop/thinkfan/metadata.xml b/app-laptop/thinkfan/metadata.xml
new file mode 100644
index 000000000000..79dc72426bd0
--- /dev/null
+++ b/app-laptop/thinkfan/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <use>
+ <flag name="atasmart">include libatasmart support to get disc temperature</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">thinkfan</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-laptop/thinkfan/thinkfan-0.9.3.ebuild b/app-laptop/thinkfan/thinkfan-0.9.3.ebuild
new file mode 100644
index 000000000000..ca8dc1c15153
--- /dev/null
+++ b/app-laptop/thinkfan/thinkfan-0.9.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils readme.gentoo-r1 systemd
+
+DESCRIPTION="simple fan control program for thinkpads"
+HOMEPAGE="http://thinkfan.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="atasmart"
+
+DEPEND="atasmart? ( dev-libs/libatasmart )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -e "s:#!/sbin/runscript:#!/sbin/openrc-run:" \
+ -i rcscripts/thinkfan.gentoo
+
+ sed -e "s:share/doc/${PN}:share/doc/${PF}:" \
+ -e "s:thinkfan.1:src/thinkfan.1:" \
+ -i CMakeLists.txt
+}
+
+src_configure() {
+ local mycmakeargs+=(
+ "-DCMAKE_BUILD_TYPE:STRING=Debug"
+ "-DUSE_ATASMART=$(usex atasmart)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ newinitd rcscripts/${PN}.gentoo ${PN}
+ systemd_dounit rcscripts/${PN}.service
+
+ readme.gentoo_create_doc
+}
+
+DOC_CONTENTS="Please read the documentation and copy an
+appropriate file to /etc/thinkfan.conf."