summaryrefslogtreecommitdiff
path: root/app-leechcraft/lc-azoth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-leechcraft/lc-azoth
reinit the tree, so we can have metadata
Diffstat (limited to 'app-leechcraft/lc-azoth')
-rw-r--r--app-leechcraft/lc-azoth/Manifest4
-rw-r--r--app-leechcraft/lc-azoth/lc-azoth-9999.ebuild116
-rw-r--r--app-leechcraft/lc-azoth/metadata.xml41
3 files changed, 161 insertions, 0 deletions
diff --git a/app-leechcraft/lc-azoth/Manifest b/app-leechcraft/lc-azoth/Manifest
new file mode 100644
index 000000000000..09d51bd3a852
--- /dev/null
+++ b/app-leechcraft/lc-azoth/Manifest
@@ -0,0 +1,4 @@
+EBUILD lc-azoth-9999.ebuild 3278 SHA256 877066927c054d541eba675118489ea69683383ab17c756e72c49575f0dc064b SHA512 9985692409082295e43735f13c9828213535c2d7dce4ee5805183a97a96e6cce8827dfd58cd09dfeff06ae0a7787898142cee62ea29ae7ef9ccb578555a62ab8 WHIRLPOOL 64236ad60b017419484bf2ef3d85d9cb70ffad483d32503aa46afbfec7788ada8f5b1ba8dbd61045dab30f6cc421c4f124a92cdfcf64b7cd2ad2defdcc1621a7
+MISC ChangeLog 2747 SHA256 0bc972da1729719ac8da11a7ad788b5e0f88b575f70fcd5ff09c330789293908 SHA512 b3c81f8cc622fee45d59bda9ba37e3d6c78beb42cc817e910a2aa2ccfc053f8c02354a9f5d84ba11730ce8d104d6558fe6028f600b51903faade039d93a8a20f WHIRLPOOL 51adb3497d6601279ca2b311f31c9622e34e8bbe8139bf8abf12bb2ffa4d8dab3827855f61bf8273254adbf07ed1d87c148f656b4b39dc82ea9c804f233b9658
+MISC ChangeLog-2015 12170 SHA256 7558f6f61efe486ed1bd5611044d6e0a79066d3636bcd74e1d39cb1c758fbc8b SHA512 5847ac210d435d06653e84cff53a52865a4ace45c60d8d37eeafb6a168f4488defa8a0bf62d736319273649a329b42e4dd2d73b258253e6842d031aee76631e5 WHIRLPOOL 60ee81565245215490e37d899d9cc744e51ee1eb7549934428c8875307b06a62176fa7267170be58ffd13f9d910961ae436547071a46a8b3edf017dcc58815d7
+MISC metadata.xml 2745 SHA256 755d1574d3d53b616bf1131c7c98cc3bdffe467c0c1f0ab811588a48eb5d7aab SHA512 08671df19283608de9e5d56c52c89bc2ee3741dd4e281fcdb1f4b159d77c30d80c248092772e700cb6901460838934db53787e3ff0dd109698a17502f8be4b63 WHIRLPOOL b9df74c2638079636ea2f960b00c0eec9a2657d8fc5feceb0f6bbb93c2dea217578a9e5bc259fc103ccfdd1abf150dc42c1ce1b1196d708ab2d257b6e7fffbad
diff --git a/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild b/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild
new file mode 100644
index 000000000000..7468a2bba2eb
--- /dev/null
+++ b/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit leechcraft
+
+DESCRIPTION="Azoth, the modular IM client for LeechCraft"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="debug doc +acetamide +adiumstyles astrality +autoidler +autopaste +birthdaynotifier
+ +chathistory +crypt +depester +embedmedia +herbicide +hili +isterique +juick
+ +keeso +lastseen +latex media +metacontacts +murm +nativeemoticons +otroid sarin
+ shx +spell +standardstyles +vader velvetbird +woodpecker +xmpp +xtazy"
+
+REQUIRED_USE="|| ( standardstyles adiumstyles )"
+
+COMMON_DEPEND="
+ ~app-leechcraft/lc-core-${PV}
+ dev-qt/qtdbus:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtxml:5
+ astrality? ( net-libs/telepathy-qt[qt5(+)] )
+ autoidler? (
+ dev-qt/qtx11extras:5
+ x11-libs/libXScrnSaver
+ )
+ crypt? ( app-crypt/qca:2[qt5] )
+ lastseen? ( dev-qt/qtconcurrent:5 )
+ media? ( dev-qt/qtmultimedia:5 )
+ otroid? (
+ dev-qt/qtconcurrent:5
+ net-libs/libotr
+ )
+ sarin? (
+ dev-qt/qtconcurrent:5
+ net-libs/tox
+ )
+ woodpecker? ( dev-libs/kqoauth )
+ xmpp? (
+ >=net-libs/qxmpp-0.9.3-r1
+ media? ( net-libs/qxmpp[speex] )
+ )
+ xtazy? ( ~app-leechcraft/lc-xtazy-${PV} )
+"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen[dot] )
+"
+RDEPEND="${COMMON_DEPEND}
+ astrality? (
+ net-im/telepathy-mission-control
+ net-voip/telepathy-haze
+ )
+ crypt? ( app-crypt/qca:2[gpg] )
+ latex? (
+ virtual/imagemagick-tools
+ virtual/latex-base
+ )
+ spell? ( ~app-leechcraft/lc-rosenthal-${PV} )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CRYPT=$(usex crypt)
+ -DWITH_DOCS=$(usex doc)
+ -DENABLE_AZOTH_ACETAMIDE=$(usex acetamide)
+ -DENABLE_AZOTH_ADIUMSTYLES=$(usex adiumstyles)
+ -DENABLE_AZOTH_ASTRALITY=$(usex astrality)
+ -DENABLE_AZOTH_AUTOIDLER=$(usex autoidler)
+ -DENABLE_AZOTH_AUTOPASTE=$(usex autopaste)
+ -DENABLE_AZOTH_BIRTHDAYNOTIFIER=$(usex birthdaynotifier)
+ -DENABLE_AZOTH_CHATHISTORY=$(usex chathistory)
+ -DENABLE_AZOTH_DEPESTER=$(usex depester)
+ -DENABLE_AZOTH_EMBEDMEDIA=$(usex embedmedia)
+ -DENABLE_AZOTH_HERBICIDE=$(usex herbicide)
+ -DENABLE_AZOTH_HILI=$(usex hili)
+ -DENABLE_AZOTH_ISTERIQUE=$(usex isterique)
+ -DENABLE_AZOTH_JUICK=$(usex juick)
+ -DENABLE_AZOTH_KEESO=$(usex keeso)
+ -DENABLE_AZOTH_LASTSEEN=$(usex lastseen)
+ -DENABLE_AZOTH_MODNOK=$(usex latex)
+ -DENABLE_AZOTH_METACONTACTS=$(usex metacontacts)
+ -DENABLE_MEDIACALLS=$(usex media)
+ -DENABLE_AZOTH_MURM=$(usex murm)
+ -DENABLE_AZOTH_NATIVEEMOTICONS=$(usex nativeemoticons)
+ -DENABLE_AZOTH_OTROID=$(usex otroid)
+ -DENABLE_AZOTH_SARIN=$(usex sarin)
+ -DENABLE_AZOTH_SHX=$(usex shx)
+ -DENABLE_AZOTH_ROSENTHAL=$(usex spell)
+ -DENABLE_AZOTH_STANDARDSTYLES=$(usex standardstyles)
+ -DENABLE_AZOTH_VADER=$(usex vader)
+ -DENABLE_AZOTH_VELVETBIRD=$(usex velvetbird)
+ -DENABLE_AZOTH_WOODPECKER=$(usex woodpecker)
+ -DENABLE_AZOTH_XOOX=$(usex xmpp)
+ -DENABLE_AZOTH_XTAZY=$(usex xtazy)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}"/out/html/*
+}
+
+pkg_postinst() {
+ if use spell; then
+ elog "You have enabled the Azoth Rosenthal plugin for"
+ elog "spellchecking. It uses Hunspell/Myspell dictionaries,"
+ elog "so install the ones for languages you use to enable"
+ elog "spellchecking."
+ fi
+}
diff --git a/app-leechcraft/lc-azoth/metadata.xml b/app-leechcraft/lc-azoth/metadata.xml
new file mode 100644
index 000000000000..25fbfb888be8
--- /dev/null
+++ b/app-leechcraft/lc-azoth/metadata.xml
@@ -0,0 +1,41 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>0xd34df00d@gmail.com</email>
+ <name>Georg Rudoy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="acetamide">Build Acetamide, the IRC protocol support</flag>
+ <flag name="adiumstyles">Build support for Adium styles</flag>
+ <flag name="astrality">Build Astrality, support for protocols provided by Telepathy</flag>
+ <flag name="autoidler">Build support for automatic status changing according to user idle time</flag>
+ <flag name="autopaste">Build Autopaste for pasting long texts to pastebins</flag>
+ <flag name="birthdaynotifier">Build Birthday Notifier for you to not forget about birthdays of your contacts.</flag>
+ <flag name="chathistory">Build ChatHistory which stories chat history</flag>
+ <flag name="depester">Build Depester which enables to ignore MUC participants</flag>
+ <flag name="embedmedia">Build EmbedMedia for embedding flash videos and images directly into chat windows</flag>
+ <flag name="herbicide">Build Herbicide, a basic antispam plugin</flag>
+ <flag name="hili">Build HiLi which allows to customize highlight settings in MUCs</flag>
+ <flag name="isterique">Build Isterique plugin for neutralizing excessive caps lock usage</flag>
+ <flag name="juick">Build plugin for the Juick.com microblogging service</flag>
+ <flag name="keeso">Build plugin for changing text into SoMEtHInG lIKe THiS</flag>
+ <flag name="lastseen">Build plugin for client-side recording of the last online/available time</flag>
+ <flag name="media">Enable media calls</flag>
+ <flag name="metacontacts">Build plugin for metacontacts support</flag>
+ <flag name="murm">Build Murm, the VKontakte messaging support via their native API (instead of XMPP)</flag>
+ <flag name="nativeemoticons">Build support for native Azoth's emoticons packs</flag>
+ <flag name="otroid">Build OTRoid, plugin for the Off-the-Record deniable encryption system</flag>
+ <flag name="sarin">Build Sarin, Tox protocol support module. Please add mva overlay to use <pkg>net-libs/tox</pkg></flag>
+ <flag name="shx">Build shell command executor plugin</flag>
+ <flag name="standardstyles">Build support for standard Azoth styles engine</flag>
+ <flag name="vader">Bulid Vader, the MRIM (Mail.Ru Agent) protocol support plugin</flag>
+ <flag name="velvetbird">Build support for protocols provided by libpurple</flag>
+ <flag name="woodpecker">Build Woodpecker, the Twitter client plugin</flag>
+ <flag name="xtazy">Build Xtazy for publishing currently playing tune</flag>
+ </use>
+</pkgmetadata>