summaryrefslogtreecommitdiff
path: root/app-leechcraft/lc-lmp/lc-lmp-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-leechcraft/lc-lmp/lc-lmp-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-leechcraft/lc-lmp/lc-lmp-9999.ebuild')
-rw-r--r--app-leechcraft/lc-lmp/lc-lmp-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-leechcraft/lc-lmp/lc-lmp-9999.ebuild b/app-leechcraft/lc-lmp/lc-lmp-9999.ebuild
new file mode 100644
index 000000000000..c5c71f57d957
--- /dev/null
+++ b/app-leechcraft/lc-lmp/lc-lmp-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit leechcraft
+
+DESCRIPTION="LeechCraft Media Player, Phonon-based audio/video player"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="debug +fradj +graffiti +mpris +mtp +mp3tunes potorchu"
+
+DEPEND="
+ ~app-leechcraft/lc-core-${PV}
+ dev-qt/qtconcurrent:5
+ dev-qt/qtdeclarative:5[widgets]
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ media-libs/gstreamer:1.0
+ media-libs/taglib
+ mpris? ( dev-qt/qtdbus:5 )
+ mtp? ( media-libs/libmtp )
+ potorchu? ( media-libs/libprojectm )"
+RDEPEND="${DEPEND}
+ graffiti? ( media-libs/flac )
+ mtp? ( ~app-leechcraft/lc-devmon-${PV} )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LMP_LIBGUESS=OFF
+ -DENABLE_LMP_FRADJ=$(usex fradj)
+ -DENABLE_LMP_GRAFFITI=$(usex graffiti)
+ -DENABLE_LMP_MP3TUNES=$(usex mp3tunes)
+ -DENABLE_LMP_MPRIS=$(usex mpris)
+ -DENABLE_LMP_MTPSYNC=$(usex mtp)
+ -DENABLE_LMP_POTORCHU=$(usex potorchu)
+ )
+ cmake-utils_src_configure
+}