summaryrefslogtreecommitdiff
path: root/app-metrics/collectd/collectd-5.12.0-r8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-06 03:21:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-06 03:21:28 +0100
commit681aad60df032a891dbbfc38f3ea4b404d6a8579 (patch)
treeda5eff2b4d9c8cca5f6df280543b43707f372f69 /app-metrics/collectd/collectd-5.12.0-r8.ebuild
parent2092ebe8b45cc45ad3357e2ccb2c37d5c1eaba2a (diff)
gentoo auto-resync : 06:08:2023 - 03:21:27
Diffstat (limited to 'app-metrics/collectd/collectd-5.12.0-r8.ebuild')
-rw-r--r--app-metrics/collectd/collectd-5.12.0-r8.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/app-metrics/collectd/collectd-5.12.0-r8.ebuild b/app-metrics/collectd/collectd-5.12.0-r8.ebuild
index 0c8c8c88baa4..06e6d5ed301c 100644
--- a/app-metrics/collectd/collectd-5.12.0-r8.ebuild
+++ b/app-metrics/collectd/collectd-5.12.0-r8.ebuild
@@ -55,7 +55,7 @@ COLLECTD_TESTED_PLUGINS="aggregation amqp apache apcups ascent battery bind
buddyinfo capabilities ceph cgroups check_uptime chrony connectivity
conntrack contextswitch cpu cpufreq cpusleep csv curl curl_json
curl_xml dbi df disk dns drbd email entropy ethstat exec fhcount
- filecount fscache gmond gps gpu_nvidia hddtemp hugepages interface ipc
+ filecount fscache gps gpu_nvidia hddtemp hugepages interface ipc
ipmi iptables ipvs irq java lua load logfile logparser log_logstash
madwifi match_empty_counter match_hashed match_regex match_timediff
match_value mbmon mcelog md memcachec memcached memory modbus mqtt
@@ -104,7 +104,6 @@ COMMON_DEPEND="
collectd_plugins_curl_xml? ( net-misc/curl:0= dev-libs/libxml2:2= )
collectd_plugins_dbi? ( dev-db/libdbi )
collectd_plugins_dns? ( net-libs/libpcap )
- collectd_plugins_gmond? ( sys-cluster/ganglia )
collectd_plugins_gps? ( sci-geosciences/gpsd:= )
collectd_plugins_gpu_nvidia? ( dev-util/nvidia-cuda-toolkit )
collectd_plugins_ipmi? ( >=sys-libs/openipmi-2.0.16-r1 )
@@ -476,10 +475,18 @@ src_install() {
newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
- sed -i -e 's:^.*PIDFile "/var/run/collectd.pid":#PIDFile "/run/collectd.pid":' "${ED}"/etc/collectd.conf || die
- sed -i -e 's:^# SocketFile "/var/run/collectd-unixsock":# SocketFile "/run/collectd/collectd.socket":' "${ED}"/etc/collectd.conf || die
- sed -i -e 's:^.*LoadPlugin perl$:# The new, correct way to load the perl plugin -- \n# <LoadPlugin perl>\n# Globals true\n# </LoadPlugin>:' "${ED}"/etc/collectd.conf || die
- sed -i -e 's:^.*LoadPlugin python$:# The new, correct way to load the python plugin -- \n# <LoadPlugin python>\n# Globals true\n# </LoadPlugin>:' "${ED}"/etc/collectd.conf || die
+ sed \
+ -e 's:^.*PIDFile "/var/run/collectd.pid":#PIDFile "/run/collectd.pid":' \
+ -i "${ED}"/etc/collectd.conf || die
+ sed \
+ -e 's:^# SocketFile "/var/run/collectd-unixsock":# SocketFile "/run/collectd/collectd.socket":' \
+ -i "${ED}"/etc/collectd.conf || die
+ sed \
+ -e 's:^.*LoadPlugin perl$:# The new, correct way to load the perl plugin -- \n# <LoadPlugin perl>\n# Globals true\n# </LoadPlugin>:' \
+ -i "${ED}"/etc/collectd.conf || die
+ sed \
+ -e 's:^.*LoadPlugin python$:# The new, correct way to load the python plugin -- \n# <LoadPlugin python>\n# Globals true\n# </LoadPlugin>:' \
+ -i "${ED}"/etc/collectd.conf || die
}
pkg_postinst() {