summaryrefslogtreecommitdiff
path: root/app-metrics/consul_exporter/consul_exporter-0.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /app-metrics/consul_exporter/consul_exporter-0.7.1.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'app-metrics/consul_exporter/consul_exporter-0.7.1.ebuild')
-rw-r--r--app-metrics/consul_exporter/consul_exporter-0.7.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-metrics/consul_exporter/consul_exporter-0.7.1.ebuild b/app-metrics/consul_exporter/consul_exporter-0.7.1.ebuild
new file mode 100644
index 000000000000..b081f85524e7
--- /dev/null
+++ b/app-metrics/consul_exporter/consul_exporter-0.7.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+CONSUL_EXPORTER_COMMIT=ae46e2e
+MY_PV="v${PV/_rc/-rc.}"
+
+DESCRIPTION="Prometheus exporter for consul metrics"
+HOMEPAGE="https://github.com/prometheus/consul_exporter"
+SRC_URI="https://github.com/prometheus/consul_exporter/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-util/promu"
+COMMON_DEPEND="acct-group/consul_exporter
+ acct-user/consul_exporter"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+RESTRICT+=" test"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s/{{.Revision}}/${CONSUL_EXPORTER_COMMIT}/" \
+ -e "s/{{.Version}}/${PV}/" \
+ .promu.yml || die "Sed failed"
+}
+
+src_compile() {
+ promu build -v || die
+}
+
+src_install() {
+ newbin ${P} ${PN}
+ dodoc {README,CONTRIBUTING}.md
+ keepdir /var/log/consul_exporter
+ fowners ${PN}:${PN} /var/log/consul_exporter
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}