summaryrefslogtreecommitdiff
path: root/app-metrics/fusioninventory-agent/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /app-metrics/fusioninventory-agent/files
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'app-metrics/fusioninventory-agent/files')
-rw-r--r--app-metrics/fusioninventory-agent/files/fusioninventory-agent-2.5.2-dirs.patch51
-rw-r--r--app-metrics/fusioninventory-agent/files/fusioninventory-agent.confd2
-rw-r--r--app-metrics/fusioninventory-agent/files/fusioninventory-agent.initd21
3 files changed, 74 insertions, 0 deletions
diff --git a/app-metrics/fusioninventory-agent/files/fusioninventory-agent-2.5.2-dirs.patch b/app-metrics/fusioninventory-agent/files/fusioninventory-agent-2.5.2-dirs.patch
new file mode 100644
index 000000000000..a3a6b439713c
--- /dev/null
+++ b/app-metrics/fusioninventory-agent/files/fusioninventory-agent-2.5.2-dirs.patch
@@ -0,0 +1,51 @@
+diff -urN a/lib/FusionInventory/Agent/Config.pm b/lib/FusionInventory/Agent/Config.pm
+--- a/lib/FusionInventory/Agent/Config.pm 2020-05-27 11:09:31.969999393 -0000
++++ b/lib/FusionInventory/Agent/Config.pm 2020-05-27 11:09:39.833332729 -0000
+@@ -67,7 +67,7 @@
+ my ($class, %params) = @_;
+
+ my $self = {
+- '_confdir' => undef, # SYSCONFDIR replaced here from Makefile
++ '_confdir' => '/etc/fusioninventory', # SYSCONFDIR replaced here from Makefile
+ };
+ bless $self, $class;
+ $self->_loadDefaults();
+diff -urN a/lib/setup.pm b/lib/setup.pm
+--- a/lib/setup.pm 2020-05-27 11:09:31.989999393 -0000
++++ b/lib/setup.pm 2020-05-27 11:11:02.233332727 -0000
+@@ -11,9 +11,9 @@
+ our @EXPORT = ('%setup');
+
+ our %setup = (
+- datadir => './share',
++ datadir => '/usr/share/fusioninventory',
+ libdir => './lib',
+- vardir => './var',
++ vardir => '/var/lib/fusioninventory',
+ );
+
+ # Compute directly libdir from this setup file as it should be installed
+diff -urN a/Makefile.PL b/Makefile.PL
+--- a/Makefile.PL 2020-05-27 11:09:31.966666059 -0000
++++ b/Makefile.PL 2020-05-27 11:09:39.833332729 -0000
+@@ -170,18 +170,15 @@
+ INSTALLSCRIPT => '$(PREFIX)/bin',
+ INSTALLSITESCRIPT => '$(PREFIX)/bin',
+ INSTALLVENDORSCRIPT => '$(PREFIX)/bin',
+- INSTALLLIB => '$(DATADIR)/lib',
+- INSTALLSITELIB => '$(DATADIR)/lib',
+- INSTALLVENDORLIB => '$(DATADIR)/lib',
+ INSTALLMAN1DIR => '$(PREFIX)/share/man/man1',
+ INSTALLSITEMAN1DIR => '$(PREFIX)/share/man/man1',
+ INSTALLVENDORMAN1DIR => '$(PREFIX)/share/man/man1',
+ INSTALLMAN3DIR => '$(PREFIX)/share/man/man3',
+ INSTALLSITEMAN3DIR => '$(PREFIX)/share/man/man3',
+ INSTALLVENDORMAN3DIR => '$(PREFIX)/share/man/man3',
+- SYSCONFDIR => '$(PREFIX)/etc/fusioninventory',
++ SYSCONFDIR => '/etc/fusioninventory',
+ DATADIR => '$(PREFIX)/share/fusioninventory',
+- LOCALSTATEDIR => '$(PREFIX)/var/fusioninventory',
++ LOCALSTATEDIR => '/var/lib/fusioninventory',
+ );
+
+ # allow variables defined on command line to override defaults
diff --git a/app-metrics/fusioninventory-agent/files/fusioninventory-agent.confd b/app-metrics/fusioninventory-agent/files/fusioninventory-agent.confd
new file mode 100644
index 000000000000..8a68458e346c
--- /dev/null
+++ b/app-metrics/fusioninventory-agent/files/fusioninventory-agent.confd
@@ -0,0 +1,2 @@
+# additional args for fusioninventory-agent
+FUSIONINVENTORY_OPTIONS=""
diff --git a/app-metrics/fusioninventory-agent/files/fusioninventory-agent.initd b/app-metrics/fusioninventory-agent/files/fusioninventory-agent.initd
new file mode 100644
index 000000000000..58bd3bbf2b45
--- /dev/null
+++ b/app-metrics/fusioninventory-agent/files/fusioninventory-agent.initd
@@ -0,0 +1,21 @@
+#!/sbin/openrc-run
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+pidfile=${RC_PREFIX%/}/run/${SVCNAME}.pid
+
+name="fusioninventory-agent daemon"
+description="FusionInventroy agent"
+command=/usr/bin/fusioninventory-agent
+command_args="--daemon --pidfile ${pidfile} ${FUSIONINVENTORY_OPTIONS}"
+extra_started_commands="reload"
+
+depend() {
+ need net
+}
+
+reload() {
+ ebegin "Reloading ${SVCNAME}"
+ start-stop-daemon --signal HUP --pidfile "${pidfile}"
+ eend $?
+}