summaryrefslogtreecommitdiff
path: root/app-metrics/mongodb_exporter/mongodb_exporter-0.11.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /app-metrics/mongodb_exporter/mongodb_exporter-0.11.1.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'app-metrics/mongodb_exporter/mongodb_exporter-0.11.1.ebuild')
-rw-r--r--app-metrics/mongodb_exporter/mongodb_exporter-0.11.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-metrics/mongodb_exporter/mongodb_exporter-0.11.1.ebuild b/app-metrics/mongodb_exporter/mongodb_exporter-0.11.1.ebuild
new file mode 100644
index 000000000000..30b674765a5d
--- /dev/null
+++ b/app-metrics/mongodb_exporter/mongodb_exporter-0.11.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+COMMIT=f5e8ebea31d6fa128ae3a2fb1b747fdf4b782b2b
+BRANCH=0.11.0
+
+DESCRIPTION="Prometheus exporter for MongoDB"
+HOMEPAGE="https://github.com/percona/mongodb_exporter"
+SRC_URI="https://github.com/percona/mongodb_exporter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 AGPL-3 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND="acct-group/mongodb_exporter
+ acct-user/mongodb_exporter"
+ DEPEND="${COMMON_DEPEND}"
+ RDEPEND="${COMMON_DEPEND}"
+
+src_compile() {
+ GOFLAGS="${GOFLAGS} -mod=vendor" emake \
+ TRAVIS_TAG="${PV}" \
+ APP_REVISION=${COMMIT} \
+ TRAVIS_BRANCH=${BRANCH} \
+ build
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc {README,CHANGELOG}.md
+ keepdir /var/log/mongodb_exporter
+ fowners ${PN}:${PN} /var/log/mongodb_exporter
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}