summaryrefslogtreecommitdiff
path: root/app-metrics/prom2json/prom2json-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-metrics/prom2json/prom2json-1.3.0.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-metrics/prom2json/prom2json-1.3.0.ebuild')
-rw-r--r--app-metrics/prom2json/prom2json-1.3.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-metrics/prom2json/prom2json-1.3.0.ebuild b/app-metrics/prom2json/prom2json-1.3.0.ebuild
new file mode 100644
index 000000000000..d90427c7afa8
--- /dev/null
+++ b/app-metrics/prom2json/prom2json-1.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+GIT_COMMIT=9180c89ee65bde2cbbe799d06d7d09e30f629984
+
+DESCRIPTION="A tool to scrape a Prometheus client and dump the result as JSON"
+HOMEPAGE="https://github.com/prometheus/prom2json"
+SRC_URI="https://github.com/prometheus/prom2json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+BDEPEND="dev-util/promu"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s/{{.Revision}}/${GIT_COMMIT}/" \
+ -e "s/{{.Version}}/${PV}/" \
+ .promu.yml || die
+}
+
+src_compile() {
+ mkdir bin || die
+ promu build --prefix bin || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc {README,CONTRIBUTING}.md
+}