summaryrefslogtreecommitdiff
path: root/app-misc/abduco
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/abduco
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/abduco')
-rw-r--r--app-misc/abduco/Manifest5
-rw-r--r--app-misc/abduco/abduco-0.5.ebuild49
-rw-r--r--app-misc/abduco/abduco-0.6.ebuild50
-rw-r--r--app-misc/abduco/metadata.xml19
4 files changed, 123 insertions, 0 deletions
diff --git a/app-misc/abduco/Manifest b/app-misc/abduco/Manifest
new file mode 100644
index 000000000000..5312a51bc7e1
--- /dev/null
+++ b/app-misc/abduco/Manifest
@@ -0,0 +1,5 @@
+DIST abduco-0.5.tar.gz 15790 BLAKE2B 6541c758aa5b2ece2f4eae744e9d9da7f8b4cf0d1e39546708e73631688d31c71c74af31e65cdb26bb046b6bf7f595409c0a71027c681fba1d4b3997020b1428 SHA512 e0772b8eecc1fb6f16c7516a6956825b9bda4149f00f56b34e68ec3544f74c2270ba8cc2642599de26ae34d11ed78b8bba70497bfc9a79f3008f50de02ce49d8
+DIST abduco-0.6.tar.gz 15829 BLAKE2B fd6c1670e0a4cf95bfaa00734b981c23877b79ffc14dadae8c84fb198cb4f585cdacf874e127190b6f8c8b784cdfa403a8be0f4cae8bc442d43723967f4525d7 SHA512 3b70a5cc10f0a2743dcbdf6eebdcfcee0e4f4ff8c6ce0bf0aa9f55c3fa85ab43aa659997735e063eab36aba69f91be7bb5519f3f632bff1b9098f5179165c1f2
+EBUILD abduco-0.5.ebuild 850 BLAKE2B bc7ef19288730e9e4c867d8df3d95f8eee6c2d7efea37347c1ea33a24f2b952d9f53c15b03c978e00c56d3d8b2d78ccada1f72202f648436e6b7084fda6c9b48 SHA512 9635efe7b043c02b3fbeee37ae1b6f3c35cd95782d4dcd7d00e0550d95b49f283419eda86f94f58849b76b2b2ca082efaeb3bd1483901d74fb94f4931ae313a2
+EBUILD abduco-0.6.ebuild 840 BLAKE2B 5dff2465e0a29ddbfe5aa217b773cf84c26601c8eab4bfb4467a7af4df9a52a74ac38af89aacd8d8b005581db75c3773ceb5b0256db2488b8f949cc5eeaaf97f SHA512 ca7b46ee13e03afa73a60f8b301b91720fef4e6aefa457cbb4e42ad3ca897f8e6a587e133f974fac6b729c9a40f0673ab2ed6e788cf677d7970edc273217f336
+MISC metadata.xml 808 BLAKE2B e82f42857bd2b16bc5d9e1990c47ef5aeec447b4e15308300fc81b8591c310a5f6b5aa7007d55cf28af7d463449b6642a7ace512c49ff20f05156f95a60ed9d3 SHA512 683ee33b44b4b6ff3c7d265a4a66b81285b1b65c94ab3264fdb502c3bb5108ae81e39b8c560675b77037ff1b8bbe46cfa714b53847bde86b1f7f590df9788e46
diff --git a/app-misc/abduco/abduco-0.5.ebuild b/app-misc/abduco/abduco-0.5.ebuild
new file mode 100644
index 000000000000..569c89575b42
--- /dev/null
+++ b/app-misc/abduco/abduco-0.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils savedconfig toolchain-funcs
+
+DESCRIPTION="lightweight session manager with {de,at}tach support"
+HOMEPAGE="http://www.brain-dump.org/projects/abduco/"
+SRC_URI="http://www.brain-dump.org/projects/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ sed -e 's:^PREFIX.*:PREFIX = /usr:' \
+ -e 's/-Os//' \
+ -e '/^CC/d' \
+ -i config.mk || die
+
+ sed -e "s/VERSION/${PV}/g" \
+ -i ${PN}.1 || die
+
+ sed -e '/@echo CC/d' \
+ -e 's|@${CC}|$(CC)|g' \
+ -i Makefile || die
+
+ restore_config config.def.h
+ epatch_user
+
+ tc-export CC
+}
+
+src_test() {
+ ./testsuite.sh || die
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README.md
+ doman ${PN}.1
+
+ save_config config.def.h
+}
diff --git a/app-misc/abduco/abduco-0.6.ebuild b/app-misc/abduco/abduco-0.6.ebuild
new file mode 100644
index 000000000000..43df63cf6123
--- /dev/null
+++ b/app-misc/abduco/abduco-0.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="lightweight session manager with {de,at}tach support"
+HOMEPAGE="http://www.brain-dump.org/projects/abduco/"
+SRC_URI="http://www.brain-dump.org/projects/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ sed -e 's:^PREFIX.*:PREFIX = /usr:' \
+ -e 's/-Os//' \
+ -e '/^CC/d' \
+ -i config.mk || die
+
+ sed -e "s/VERSION/${PV}/g" \
+ -i ${PN}.1 || die
+
+ sed -e '/@echo CC/d' \
+ -e 's|@${CC}|$(CC)|g' \
+ -i Makefile || die
+
+ restore_config config.def.h
+
+ tc-export CC
+
+ default
+}
+
+src_test() {
+ ./testsuite.sh || die
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README.md
+ doman ${PN}.1
+
+ save_config config.def.h
+}
diff --git a/app-misc/abduco/metadata.xml b/app-misc/abduco/metadata.xml
new file mode 100644
index 000000000000..b5007ff63a3f
--- /dev/null
+++ b/app-misc/abduco/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>hendrik@consetetur.de</email>
+ <name>Hendrik v. Raven (lorem_ipsum)</name>
+</maintainer>
+<maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+</maintainer>
+<maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+</maintainer>
+<longdescription lang="en">
+ abduco provides session management i.e. it allows programs to be run independently from its controlling terminal. That is programs can be detached - run in the background - and then later reattached. Together with dvtm it provides a simpler and cleaner alternative to tmux or screen.
+</longdescription>
+</pkgmetadata>