summaryrefslogtreecommitdiff
path: root/app-misc/beancounter/beancounter-0.8.10-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /app-misc/beancounter/beancounter-0.8.10-r2.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'app-misc/beancounter/beancounter-0.8.10-r2.ebuild')
-rw-r--r--app-misc/beancounter/beancounter-0.8.10-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/beancounter/beancounter-0.8.10-r2.ebuild b/app-misc/beancounter/beancounter-0.8.10-r2.ebuild
new file mode 100644
index 000000000000..7435d61063e1
--- /dev/null
+++ b/app-misc/beancounter/beancounter-0.8.10-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Finance performance calculation engine with full data acquisition, SQL support"
+HOMEPAGE="https://dirk.eddelbuettel.com/code/beancounter.html"
+SRC_URI="https://eddelbuettel.com/dirk/code/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mysql postgres sqlite"
+
+DEPEND="dev-perl/Date-Manip
+ dev-perl/Statistics-Descriptive
+ dev-perl/Finance-YahooQuote
+ dev-perl/libwww-perl
+ mysql? ( dev-perl/DBD-mysql )
+ sqlite? ( dev-perl/DBD-SQLite )
+ postgres? ( dev-perl/DBD-Pg )"
+RDEPEND="${DEPEND}
+ dev-perl/DBI"
+
+mydoc="README example.beancounterrc beancounter_*.txt "
+
+src_install() {
+ perl-module_src_install
+ # rm unwanted READMEs
+ rm "${ED}"/usr/share/doc/${PF}/{README.Debian,README.non-gnu} || die
+}