summaryrefslogtreecommitdiff
path: root/app-misc/c_rehash/c_rehash-1.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /app-misc/c_rehash/c_rehash-1.7-r1.ebuild
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'app-misc/c_rehash/c_rehash-1.7-r1.ebuild')
-rw-r--r--app-misc/c_rehash/c_rehash-1.7-r1.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/app-misc/c_rehash/c_rehash-1.7-r1.ebuild b/app-misc/c_rehash/c_rehash-1.7-r1.ebuild
index 4f631bdca8e1..5ad7624ea5b6 100644
--- a/app-misc/c_rehash/c_rehash-1.7-r1.ebuild
+++ b/app-misc/c_rehash/c_rehash-1.7-r1.ebuild
@@ -1,31 +1,28 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
DESCRIPTION="c_rehash script from OpenSSL"
HOMEPAGE="https://www.openssl.org/ https://github.com/pld-linux/openssl/"
SRC_URI="https://cvs.pld-linux.org/cgi-bin/cvsweb.cgi/packages/openssl/openssl-c_rehash.sh?rev=${PV} -> openssl-c_rehash.sh.${PV}"
+S="${WORKDIR}"
LICENSE="openssl"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-IUSE=""
RDEPEND="!<dev-libs/openssl-1.0.2d-r1:0"
DEPEND="${RDEPEND}"
-S=${WORKDIR}
-
-src_prepare() {
- SSL_CNF_DIR="/etc/ssl"
+src_configure() {
sed \
- -e "/^DIR=/s:=.*:=${EPREFIX}${SSL_CNF_DIR}:" \
+ -e "/^DIR=/s:=.*:=${EPREFIX}/etc/ssl:" \
-e "s:SSL_CMD=/usr:SSL_CMD=${EPREFIX}/usr:" \
"${DISTDIR}"/openssl-c_rehash.sh.${PV} \
> "${WORKDIR}"/c_rehash || die #416717
}
src_install() {
- dobin "${WORKDIR}"/c_rehash
+ dobin c_rehash
}