summaryrefslogtreecommitdiff
path: root/app-misc/cdctl/cdctl-0.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/cdctl/cdctl-0.16.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/cdctl/cdctl-0.16.ebuild')
-rw-r--r--app-misc/cdctl/cdctl-0.16.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/cdctl/cdctl-0.16.ebuild b/app-misc/cdctl/cdctl-0.16.ebuild
new file mode 100644
index 000000000000..3dff479be49b
--- /dev/null
+++ b/app-misc/cdctl/cdctl-0.16.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils autotools toolchain-funcs
+
+DESCRIPTION="Utility to control your cd/dvd drive"
+HOMEPAGE="http://cdctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cdctl/${P}.tar.gz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.16-Makefile.in.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}