summaryrefslogtreecommitdiff
path: root/app-misc/cdspeed/cdspeed-0.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /app-misc/cdspeed/cdspeed-0.4-r2.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'app-misc/cdspeed/cdspeed-0.4-r2.ebuild')
-rw-r--r--app-misc/cdspeed/cdspeed-0.4-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/cdspeed/cdspeed-0.4-r2.ebuild b/app-misc/cdspeed/cdspeed-0.4-r2.ebuild
new file mode 100644
index 000000000000..6c933ac2caff
--- /dev/null
+++ b/app-misc/cdspeed/cdspeed-0.4-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Change the speed of your CD drive"
+HOMEPAGE="http://linuxfocus.org/~guido/"
+SRC_URI="http://linuxfocus.org/~guido/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~x86"
+
+src_prepare() {
+ default
+ sed -i Makefile \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -Wall -Wno-unused" CC=$(tc-getCC)
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+ dodoc README
+}