summaryrefslogtreecommitdiff
path: root/app-misc/check-jsonschema/check-jsonschema-0.21.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-02 03:06:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-02 03:06:27 +0000
commitc8273339188289fe8571e5a8cb9e00e59a46aaaf (patch)
tree793a97e856b00e8c923cb6b505ea175f89b35cf2 /app-misc/check-jsonschema/check-jsonschema-0.21.0-r1.ebuild
parent60f657b5e6155f26601c7def7baa11cee72246d0 (diff)
gentoo auto-resync : 02:02:2023 - 03:06:27
Diffstat (limited to 'app-misc/check-jsonschema/check-jsonschema-0.21.0-r1.ebuild')
-rw-r--r--app-misc/check-jsonschema/check-jsonschema-0.21.0-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-misc/check-jsonschema/check-jsonschema-0.21.0-r1.ebuild b/app-misc/check-jsonschema/check-jsonschema-0.21.0-r1.ebuild
new file mode 100644
index 000000000000..f7caec002ba3
--- /dev/null
+++ b/app-misc/check-jsonschema/check-jsonschema-0.21.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A CLI and set of pre-commit hooks for jsonschema validation"
+HOMEPAGE="
+ https://pypi.org/project/check-jsonschema/
+ https://github.com/python-jsonschema/check-jsonschema
+"
+SRC_URI="https://github.com/python-jsonschema/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=(
+ README.md
+ CONTRIBUTING.md
+ CHANGELOG.rst
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/furo
+
+python_prepare_all() {
+ # relax deps in setup.cfg
+ sed -r -e 's:([a-zA-Z.-]+)([<>]|==|[<>]=)+.+:\1: ; /importlib-resources/ d' -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}