summaryrefslogtreecommitdiff
path: root/app-misc/ddate/ddate-0.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/ddate/ddate-0.2.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/ddate/ddate-0.2.1.ebuild')
-rw-r--r--app-misc/ddate/ddate-0.2.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/ddate/ddate-0.2.1.ebuild b/app-misc/ddate/ddate-0.2.1.ebuild
new file mode 100644
index 000000000000..15f0af09a9fe
--- /dev/null
+++ b/app-misc/ddate/ddate-0.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Perpetual date converter from gregorian to poee calendar"
+HOMEPAGE="https://github.com/bo0ts/ddate"
+SRC_URI="https://github.com/bo0ts/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="!<sys-apps/util-linux-2.20
+ !<sys-apps/util-linux-2.23[ddate]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e '/gzip/d' CMakeLists.txt || die
+}
+
+src_install() {
+ dobin "${CMAKE_BUILD_DIR}"/${PN}
+ doman ${PN}.1
+ dodoc README.org
+}