summaryrefslogtreecommitdiff
path: root/app-misc/detachtty/detachtty-11.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
commit09351e78166b5e864197c4456ebae3f89dd0bed9 (patch)
tree41a96399f56ed3aa399006871bfce4430db84aa2 /app-misc/detachtty/detachtty-11.0.0.ebuild
parentc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (diff)
gentoo resync : 22.01.2019
Diffstat (limited to 'app-misc/detachtty/detachtty-11.0.0.ebuild')
-rw-r--r--app-misc/detachtty/detachtty-11.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-misc/detachtty/detachtty-11.0.0.ebuild b/app-misc/detachtty/detachtty-11.0.0.ebuild
new file mode 100644
index 000000000000..570e3b528b6f
--- /dev/null
+++ b/app-misc/detachtty/detachtty-11.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Attach/detach from interactive processes across the network"
+HOMEPAGE="https://github.com/cosmos72/detachtty"
+SRC_URI="https://github.com/cosmos72/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin attachtty detachtty
+ doman "${PN}.1"
+ dosym detachtty.1 /usr/share/man/man1/attachtty.1
+ einstalldocs
+}