summaryrefslogtreecommitdiff
path: root/app-misc/detox/detox-1.2.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/detox/detox-1.2.0-r3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/detox/detox-1.2.0-r3.ebuild')
-rw-r--r--app-misc/detox/detox-1.2.0-r3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-misc/detox/detox-1.2.0-r3.ebuild b/app-misc/detox/detox-1.2.0-r3.ebuild
new file mode 100644
index 000000000000..cbae89b41864
--- /dev/null
+++ b/app-misc/detox/detox-1.2.0-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+MY_P="${PN}-${PV/_/-}"
+
+DESCRIPTION="Safely remove spaces and strange characters from filenames"
+HOMEPAGE="http://detox.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~mips ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}"/${MY_P}
+
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-parallel.patch
+ "${FILESDIR}"/${P}-LDFLAGS.patch
+ "${FILESDIR}"/${P}-change-default-sequence-to-use-utf8-table.patch
+ "${FILESDIR}"/${P}-install-missing-file.patch
+ "${FILESDIR}"/${P}-format-security.patch
+ )
+
+src_prepare() {
+ sed \
+ -e 's:Fl c Ar:Fl f Ar:g' \
+ -i ${PN}.1 || die
+ epatch "${PATCHES[@]}"
+ sed \
+ -e '/detoxrc.sample/d' \
+ -i Makefile.in || die
+}
+
+src_configure() {
+ econf --with-popt="${EPREFIX}/usr"
+}