summaryrefslogtreecommitdiff
path: root/app-misc/detox/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/detox/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/detox/files')
-rw-r--r--app-misc/detox/files/detox-1.2.0-LDFLAGS.patch18
-rw-r--r--app-misc/detox/files/detox-1.2.0-change-default-sequence-to-use-utf8-table.patch17
-rw-r--r--app-misc/detox/files/detox-1.2.0-format-security.patch72
-rw-r--r--app-misc/detox/files/detox-1.2.0-install-missing-file.patch18
-rw-r--r--app-misc/detox/files/detox-1.2.0-parallel.patch29
5 files changed, 154 insertions, 0 deletions
diff --git a/app-misc/detox/files/detox-1.2.0-LDFLAGS.patch b/app-misc/detox/files/detox-1.2.0-LDFLAGS.patch
new file mode 100644
index 000000000000..3f0daa088010
--- /dev/null
+++ b/app-misc/detox/files/detox-1.2.0-LDFLAGS.patch
@@ -0,0 +1,18 @@
+https://sourceforge.net/tracker/index.php?func=detail&aid=2166388&group_id=101612&atid=630105
+
+--- Makefile.in 2008-10-14 16:37:22 +0000
++++ Makefile.in 2008-10-14 16:38:17 +0000
+@@ -70,10 +70,10 @@
+ #
+
+ detox: ${detoxOBJS}
+- ${CC} -o detox ${detoxOBJS} ${L_OPT}
++ ${CC} ${LDFLAGS} -o detox ${detoxOBJS} ${L_OPT}
+
+ inline-detox: ${inline-detoxOBJS}
+- ${CC} -o inline-detox ${inline-detoxOBJS} ${L_OPT}
++ ${CC} ${LDFLAGS} -o inline-detox ${inline-detoxOBJS} ${L_OPT}
+
+ #
+ # Special Source Compiles
+
diff --git a/app-misc/detox/files/detox-1.2.0-change-default-sequence-to-use-utf8-table.patch b/app-misc/detox/files/detox-1.2.0-change-default-sequence-to-use-utf8-table.patch
new file mode 100644
index 000000000000..2e54642f45b9
--- /dev/null
+++ b/app-misc/detox/files/detox-1.2.0-change-default-sequence-to-use-utf8-table.patch
@@ -0,0 +1,17 @@
+# Patch from Teemu Likonen <tlikonen@iki.fi>
+# to change the default sequence to use utf8 instead of iso8859-1
+--- detox-1.2.0/detoxrc~ 2006-07-03 19:45:54.000000000 +0300
++++ detox-1.2.0/detoxrc 2009-05-28 15:34:26.497832449 +0300
+@@ -32,10 +32,10 @@
+ #
+
+ #
+-# Basically just ISO8859_1
++# Basically just utf_8
+ #
+ sequence default {
+- iso8859_1;
++ utf_8;
+ safe;
+ wipeup;
+ };
diff --git a/app-misc/detox/files/detox-1.2.0-format-security.patch b/app-misc/detox/files/detox-1.2.0-format-security.patch
new file mode 100644
index 000000000000..c03a98aa046c
--- /dev/null
+++ b/app-misc/detox/files/detox-1.2.0-format-security.patch
@@ -0,0 +1,72 @@
+ parse_options_getopt.c | 8 ++++----
+ parse_options_popt.c | 8 ++++----
+ 2 files changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/parse_options_getopt.c b/parse_options_getopt.c
+index 1f80966..ea2b266 100644
+--- a/parse_options_getopt.c
++++ b/parse_options_getopt.c
+@@ -98,9 +98,9 @@ struct detox_options *parse_options_getopt(int argc, char **argv)
+ #endif
+ switch (optcode) {
+ case 'h':
+- printf(usage_message);
++ printf("%s", usage_message);
+ printf("\n");
+- printf(help_message);
++ printf("%s", help_message);
+ exit(EXIT_SUCCESS);
+
+ case 'f':
+@@ -138,7 +138,7 @@ struct detox_options *parse_options_getopt(int argc, char **argv)
+ exit(EXIT_SUCCESS);
+
+ case '?':
+- printf(usage_message);
++ printf("%s", usage_message);
+ exit(EXIT_SUCCESS);
+
+ case 0:
+@@ -195,7 +195,7 @@ struct detox_options *parse_options_getopt(int argc, char **argv)
+ }
+ else {
+ #ifndef INLINE_MODE
+- printf(usage_message);
++ printf("%s", usage_message);
+ exit(EXIT_FAILURE);
+ #endif
+ }
+diff --git a/parse_options_popt.c b/parse_options_popt.c
+index 60dad7a..370c3cc 100644
+--- a/parse_options_popt.c
++++ b/parse_options_popt.c
+@@ -94,9 +94,9 @@ struct detox_options *parse_options_popt(int argc, const char **argv)
+ while ((c = poptGetNextOpt(optCon)) >= 0) {
+ switch (c) {
+ case 'h':
+- printf(usage_message);
++ printf("%s", usage_message);
+ printf("\n");
+- printf(help_message);
++ printf("%s", help_message);
+ exit(EXIT_SUCCESS);
+
+ case 'f':
+@@ -142,7 +142,7 @@ struct detox_options *parse_options_popt(int argc, const char **argv)
+ break;
+
+ case '?':
+- printf(usage_message);
++ printf("%s", usage_message);
+ exit(EXIT_SUCCESS);
+
+ }
+@@ -177,7 +177,7 @@ struct detox_options *parse_options_popt(int argc, const char **argv)
+
+ #ifndef INLINE_MODE
+ if (i == 0) {
+- fprintf(stderr, usage_message);
++ fprintf(stderr, "%s", usage_message);
+ exit(EXIT_FAILURE);
+ }
+ #endif
diff --git a/app-misc/detox/files/detox-1.2.0-install-missing-file.patch b/app-misc/detox/files/detox-1.2.0-install-missing-file.patch
new file mode 100644
index 000000000000..97863268bc48
--- /dev/null
+++ b/app-misc/detox/files/detox-1.2.0-install-missing-file.patch
@@ -0,0 +1,18 @@
+# Patch by Nelson A. de Oliveira <naoliv@debian.org>
+#
+# Patch upstream Makefile to install missing safe.tbl (#566785)
+
+--- detox-1.2.0/Makefile.in 2010-06-20 23:41:34.000000000 -0300
++++ detox-1.2.0/Makefile.in 2010-06-20 23:42:34.000000000 -0300
+@@ -147,6 +147,11 @@
+ else \
+ echo "${DESTDIR}${datadir}/detox/unicode.tbl exists, skipping"; \
+ fi
++ @if [ ! -f ${DESTDIR}${datadir}/detox/safe.tbl ]; then \
++ ${INSTALL} -m 644 safe.tbl ${DESTDIR}${datadir}/detox; \
++ else \
++ echo "${DESTDIR}${datadir}/detox/safe.tbl exists, skipping"; \
++ fi
+
+ install-unsafe-config: install-base
+ ${INSTALL} -m 644 detoxrc ${DESTDIR}${sysconfdir}
diff --git a/app-misc/detox/files/detox-1.2.0-parallel.patch b/app-misc/detox/files/detox-1.2.0-parallel.patch
new file mode 100644
index 000000000000..73abd73d61b3
--- /dev/null
+++ b/app-misc/detox/files/detox-1.2.0-parallel.patch
@@ -0,0 +1,29 @@
+https://sourceforge.net/tracker/index.php?func=detail&aid=2166387&group_id=101612&atid=630105
+
+--- Makefile.in 2008-10-14 16:39:34 +0000
++++ Makefile.in 2008-10-14 16:38:51 +0000
+@@ -131,7 +131,7 @@
+ ${INSTALL} -m 644 detox.1 ${DESTDIR}${mandir}/man1
+ ${INSTALL} -m 644 detoxrc.5 detox.tbl.5 ${DESTDIR}${mandir}/man5
+
+-install-safe-config:
++install-safe-config: install-base
+ @if [ ! -f ${DESTDIR}${sysconfdir}/detoxrc ]; then \
+ ${INSTALL} -m 644 detoxrc ${DESTDIR}${sysconfdir}; \
+ else \
+@@ -148,12 +148,12 @@
+ echo "${DESTDIR}${datadir}/detox/unicode.tbl exists, skipping"; \
+ fi
+
+-install-unsafe-config:
++install-unsafe-config: install-base
+ ${INSTALL} -m 644 detoxrc ${DESTDIR}${sysconfdir}
+ ${INSTALL} -m 644 iso8859_1.tbl ${DESTDIR}${datadir}/detox
+ ${INSTALL} -m 644 unicode.tbl ${DESTDIR}${datadir}/detox
+
+-install-sample-config:
++install-sample-config: install-base
+ ${INSTALL} -m 644 detoxrc ${DESTDIR}${sysconfdir}/detoxrc.sample
+ ${INSTALL} -m 644 iso8859_1.tbl ${DESTDIR}${datadir}/detox/iso8859_1.tbl.sample
+ ${INSTALL} -m 644 unicode.tbl ${DESTDIR}${datadir}/detox/unicode.tbl.sample
+