summaryrefslogtreecommitdiff
path: root/app-misc/detox/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-misc/detox/files
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/detox/files')
-rw-r--r--app-misc/detox/files/detox-1.2.0-LDFLAGS.patch18
-rw-r--r--app-misc/detox/files/detox-1.2.0-change-default-sequence-to-use-utf8-table.patch17
-rw-r--r--app-misc/detox/files/detox-1.2.0-format-security.patch72
-rw-r--r--app-misc/detox/files/detox-1.2.0-install-missing-file.patch18
-rw-r--r--app-misc/detox/files/detox-1.2.0-parallel.patch29
5 files changed, 0 insertions, 154 deletions
diff --git a/app-misc/detox/files/detox-1.2.0-LDFLAGS.patch b/app-misc/detox/files/detox-1.2.0-LDFLAGS.patch
deleted file mode 100644
index 3f0daa088010..000000000000
--- a/app-misc/detox/files/detox-1.2.0-LDFLAGS.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-https://sourceforge.net/tracker/index.php?func=detail&aid=2166388&group_id=101612&atid=630105
-
---- Makefile.in 2008-10-14 16:37:22 +0000
-+++ Makefile.in 2008-10-14 16:38:17 +0000
-@@ -70,10 +70,10 @@
- #
-
- detox: ${detoxOBJS}
-- ${CC} -o detox ${detoxOBJS} ${L_OPT}
-+ ${CC} ${LDFLAGS} -o detox ${detoxOBJS} ${L_OPT}
-
- inline-detox: ${inline-detoxOBJS}
-- ${CC} -o inline-detox ${inline-detoxOBJS} ${L_OPT}
-+ ${CC} ${LDFLAGS} -o inline-detox ${inline-detoxOBJS} ${L_OPT}
-
- #
- # Special Source Compiles
-
diff --git a/app-misc/detox/files/detox-1.2.0-change-default-sequence-to-use-utf8-table.patch b/app-misc/detox/files/detox-1.2.0-change-default-sequence-to-use-utf8-table.patch
deleted file mode 100644
index 2e54642f45b9..000000000000
--- a/app-misc/detox/files/detox-1.2.0-change-default-sequence-to-use-utf8-table.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-# Patch from Teemu Likonen <tlikonen@iki.fi>
-# to change the default sequence to use utf8 instead of iso8859-1
---- detox-1.2.0/detoxrc~ 2006-07-03 19:45:54.000000000 +0300
-+++ detox-1.2.0/detoxrc 2009-05-28 15:34:26.497832449 +0300
-@@ -32,10 +32,10 @@
- #
-
- #
--# Basically just ISO8859_1
-+# Basically just utf_8
- #
- sequence default {
-- iso8859_1;
-+ utf_8;
- safe;
- wipeup;
- };
diff --git a/app-misc/detox/files/detox-1.2.0-format-security.patch b/app-misc/detox/files/detox-1.2.0-format-security.patch
deleted file mode 100644
index c03a98aa046c..000000000000
--- a/app-misc/detox/files/detox-1.2.0-format-security.patch
+++ /dev/null
@@ -1,72 +0,0 @@
- parse_options_getopt.c | 8 ++++----
- parse_options_popt.c | 8 ++++----
- 2 files changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/parse_options_getopt.c b/parse_options_getopt.c
-index 1f80966..ea2b266 100644
---- a/parse_options_getopt.c
-+++ b/parse_options_getopt.c
-@@ -98,9 +98,9 @@ struct detox_options *parse_options_getopt(int argc, char **argv)
- #endif
- switch (optcode) {
- case 'h':
-- printf(usage_message);
-+ printf("%s", usage_message);
- printf("\n");
-- printf(help_message);
-+ printf("%s", help_message);
- exit(EXIT_SUCCESS);
-
- case 'f':
-@@ -138,7 +138,7 @@ struct detox_options *parse_options_getopt(int argc, char **argv)
- exit(EXIT_SUCCESS);
-
- case '?':
-- printf(usage_message);
-+ printf("%s", usage_message);
- exit(EXIT_SUCCESS);
-
- case 0:
-@@ -195,7 +195,7 @@ struct detox_options *parse_options_getopt(int argc, char **argv)
- }
- else {
- #ifndef INLINE_MODE
-- printf(usage_message);
-+ printf("%s", usage_message);
- exit(EXIT_FAILURE);
- #endif
- }
-diff --git a/parse_options_popt.c b/parse_options_popt.c
-index 60dad7a..370c3cc 100644
---- a/parse_options_popt.c
-+++ b/parse_options_popt.c
-@@ -94,9 +94,9 @@ struct detox_options *parse_options_popt(int argc, const char **argv)
- while ((c = poptGetNextOpt(optCon)) >= 0) {
- switch (c) {
- case 'h':
-- printf(usage_message);
-+ printf("%s", usage_message);
- printf("\n");
-- printf(help_message);
-+ printf("%s", help_message);
- exit(EXIT_SUCCESS);
-
- case 'f':
-@@ -142,7 +142,7 @@ struct detox_options *parse_options_popt(int argc, const char **argv)
- break;
-
- case '?':
-- printf(usage_message);
-+ printf("%s", usage_message);
- exit(EXIT_SUCCESS);
-
- }
-@@ -177,7 +177,7 @@ struct detox_options *parse_options_popt(int argc, const char **argv)
-
- #ifndef INLINE_MODE
- if (i == 0) {
-- fprintf(stderr, usage_message);
-+ fprintf(stderr, "%s", usage_message);
- exit(EXIT_FAILURE);
- }
- #endif
diff --git a/app-misc/detox/files/detox-1.2.0-install-missing-file.patch b/app-misc/detox/files/detox-1.2.0-install-missing-file.patch
deleted file mode 100644
index 97863268bc48..000000000000
--- a/app-misc/detox/files/detox-1.2.0-install-missing-file.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-# Patch by Nelson A. de Oliveira <naoliv@debian.org>
-#
-# Patch upstream Makefile to install missing safe.tbl (#566785)
-
---- detox-1.2.0/Makefile.in 2010-06-20 23:41:34.000000000 -0300
-+++ detox-1.2.0/Makefile.in 2010-06-20 23:42:34.000000000 -0300
-@@ -147,6 +147,11 @@
- else \
- echo "${DESTDIR}${datadir}/detox/unicode.tbl exists, skipping"; \
- fi
-+ @if [ ! -f ${DESTDIR}${datadir}/detox/safe.tbl ]; then \
-+ ${INSTALL} -m 644 safe.tbl ${DESTDIR}${datadir}/detox; \
-+ else \
-+ echo "${DESTDIR}${datadir}/detox/safe.tbl exists, skipping"; \
-+ fi
-
- install-unsafe-config: install-base
- ${INSTALL} -m 644 detoxrc ${DESTDIR}${sysconfdir}
diff --git a/app-misc/detox/files/detox-1.2.0-parallel.patch b/app-misc/detox/files/detox-1.2.0-parallel.patch
deleted file mode 100644
index 73abd73d61b3..000000000000
--- a/app-misc/detox/files/detox-1.2.0-parallel.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-https://sourceforge.net/tracker/index.php?func=detail&aid=2166387&group_id=101612&atid=630105
-
---- Makefile.in 2008-10-14 16:39:34 +0000
-+++ Makefile.in 2008-10-14 16:38:51 +0000
-@@ -131,7 +131,7 @@
- ${INSTALL} -m 644 detox.1 ${DESTDIR}${mandir}/man1
- ${INSTALL} -m 644 detoxrc.5 detox.tbl.5 ${DESTDIR}${mandir}/man5
-
--install-safe-config:
-+install-safe-config: install-base
- @if [ ! -f ${DESTDIR}${sysconfdir}/detoxrc ]; then \
- ${INSTALL} -m 644 detoxrc ${DESTDIR}${sysconfdir}; \
- else \
-@@ -148,12 +148,12 @@
- echo "${DESTDIR}${datadir}/detox/unicode.tbl exists, skipping"; \
- fi
-
--install-unsafe-config:
-+install-unsafe-config: install-base
- ${INSTALL} -m 644 detoxrc ${DESTDIR}${sysconfdir}
- ${INSTALL} -m 644 iso8859_1.tbl ${DESTDIR}${datadir}/detox
- ${INSTALL} -m 644 unicode.tbl ${DESTDIR}${datadir}/detox
-
--install-sample-config:
-+install-sample-config: install-base
- ${INSTALL} -m 644 detoxrc ${DESTDIR}${sysconfdir}/detoxrc.sample
- ${INSTALL} -m 644 iso8859_1.tbl ${DESTDIR}${datadir}/detox/iso8859_1.tbl.sample
- ${INSTALL} -m 644 unicode.tbl ${DESTDIR}${datadir}/detox/unicode.tbl.sample
-