summaryrefslogtreecommitdiff
path: root/app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild')
-rw-r--r--app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild b/app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild
new file mode 100644
index 000000000000..883ebd7c7fee
--- /dev/null
+++ b/app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1
+
+MY_PV="${PV//_beta/-beta}"
+DESCRIPTION="DF-SHOW is a Unix-like rewrite of some of the applications from DF-EDIT"
+HOMEPAGE="https://github.com/roberthawdon/dfshow"
+SRC_URI="https://github.com/roberthawdon/dfshow/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/libconfig:=
+ sys-libs/ncurses:0=
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i 's/LDADD = -lncursesw -lm -lconfig/LDADD = -lncursesw -lm -lconfig -ltinfow/' Makefile.am ||
+ die "sed in Makefile.am failed"
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newbashcomp "${S}/misc/auto-completion/bash/sf-completion.bash" sf-completion
+ newbashcomp "${S}/misc/auto-completion/bash/show-completion.bash" show-completion
+
+ insinto /usr/share/zsh/site-functions
+ doins "${S}/misc/auto-completion/zsh/_sf"
+ doins "${S}/misc/auto-completion/zsh/_show"
+}