summaryrefslogtreecommitdiff
path: root/app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild')
-rw-r--r--app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild b/app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild
index 883ebd7c7fee..d6a901fd6e7d 100644
--- a/app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild
+++ b/app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools bash-completion-r1
+inherit autotools bash-completion-r1 flag-o-matic
MY_PV="${PV//_beta/-beta}"
DESCRIPTION="DF-SHOW is a Unix-like rewrite of some of the applications from DF-EDIT"
@@ -19,11 +19,20 @@ DEPEND="dev-libs/libconfig:=
sys-libs/ncurses:0=
"
RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.1_beta-use-PKG_CHECK_MODULES-for-ncurses-libconfig.patch
+)
src_prepare() {
default
- sed -i 's/LDADD = -lncursesw -lm -lconfig/LDADD = -lncursesw -lm -lconfig -ltinfow/' Makefile.am ||
- die "sed in Makefile.am failed"
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # Standard on macOS
+ # No real motivation to push libtool upstream just for this
+ append-ldflags -Wl,-undefined -Wl,dynamic_lookup
+ fi
eautoreconf
}