summaryrefslogtreecommitdiff
path: root/app-misc/fdupes/fdupes-1.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/fdupes/fdupes-1.6.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/fdupes/fdupes-1.6.1.ebuild')
-rw-r--r--app-misc/fdupes/fdupes-1.6.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/fdupes/fdupes-1.6.1.ebuild b/app-misc/fdupes/fdupes-1.6.1.ebuild
new file mode 100644
index 000000000000..2858047c4d5b
--- /dev/null
+++ b/app-misc/fdupes/fdupes-1.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Identify/delete duplicate files residing within specified directories"
+HOMEPAGE="https://github.com/adrianlopezroche/fdupes"
+SRC_URI="https://github.com/adrianlopezroche/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+src_prepare() {
+ append-lfs-flags
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin fdupes
+ doman fdupes.1
+ dodoc CHANGES CONTRIBUTORS README TODO
+}