summaryrefslogtreecommitdiff
path: root/app-misc/fmawk/fmawk-1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /app-misc/fmawk/fmawk-1.3.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'app-misc/fmawk/fmawk-1.3.ebuild')
-rw-r--r--app-misc/fmawk/fmawk-1.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/fmawk/fmawk-1.3.ebuild b/app-misc/fmawk/fmawk-1.3.ebuild
new file mode 100644
index 000000000000..188ad7e91e82
--- /dev/null
+++ b/app-misc/fmawk/fmawk-1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="File manager written in awk"
+HOMEPAGE="https://github.com/huijunchen9260/fm.awk/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/huijunchen9260/fm.awk.git"
+else
+ SRC_URI="https://github.com/huijunchen9260/fm.awk/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/fm.awk-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="virtual/awk"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "PDFs preview" app-text/poppler
+ optfeature "images preview" media-gfx/chafa
+ optfeature "videos preview" media-video/ffmpegthumbnailer
+}