summaryrefslogtreecommitdiff
path: root/app-misc/glastree/glastree-1.04_p20150525.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /app-misc/glastree/glastree-1.04_p20150525.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'app-misc/glastree/glastree-1.04_p20150525.ebuild')
-rw-r--r--app-misc/glastree/glastree-1.04_p20150525.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/glastree/glastree-1.04_p20150525.ebuild b/app-misc/glastree/glastree-1.04_p20150525.ebuild
new file mode 100644
index 000000000000..8e8a41a96311
--- /dev/null
+++ b/app-misc/glastree/glastree-1.04_p20150525.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT="1dc111308356d999f2a32aa50b6a0737ec5e6b09"
+DESCRIPTION="glastree is a poor mans snapshot utility using hardlinks written in perl"
+HOMEPAGE="http://www.igmus.org/code/"
+SRC_URI="https://github.com/jeremywohl/glastree/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Date-Calc
+"
+BDEPEND="test? ( ${RDEPEND} )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-posix-make.patch
+)
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/man/man1
+ emake INSTROOT="${ED}"/usr INSTMAN=share/man install
+ dodoc README CHANGES THANKS
+}