summaryrefslogtreecommitdiff
path: root/app-misc/gnote
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /app-misc/gnote
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'app-misc/gnote')
-rw-r--r--app-misc/gnote/Manifest2
-rw-r--r--app-misc/gnote/gnote-3.30.0.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
index e7efdbb20dc9..7d337a070581 100644
--- a/app-misc/gnote/Manifest
+++ b/app-misc/gnote/Manifest
@@ -1,3 +1,5 @@
DIST gnote-3.24.1.tar.xz 3310012 BLAKE2B b6167dbb2461e574e4f21b2f227eb9a3c89708ddd15a561146faa044130e5c9ccc6d64b4923c30726160ee35d4ab5a0ae04b1593e74af2fa6566582af9bc1f18 SHA512 759fb2984312a3e3d5aed9b79f2309021b69df57b820d34814a5d3d9b5c9201abc6e50d83bf64f30974991d779b0b85e599435a24ee1326b867a2a4be8e0f37e
+DIST gnote-3.30.0.tar.xz 4017364 BLAKE2B e53240162d4814a0f004863ca5d309dce0b428d8ce4f7e8dc64c0ce683a830ebedc4809191e55818dba98de7d968413ae080f86367abacf3e4f3a404bbd62157 SHA512 7c1348b9fdbc84ea8cc74e214de50b594a1585031a40406ba73a8635362ef1769a37dbce79347188983970debf72d3c0f81523739a48bf27823f0233cc6cfd2b
EBUILD gnote-3.24.1.ebuild 1547 BLAKE2B 8a0e15ea352c054b0d777386d798334f921e5778c462822e932a5f21f0442b7bd71738f4ebc91ada4f6eb58c60af5d4876bc0265d0d283fcbe925cc4c8ce2bd7 SHA512 6144bccd5cd942f967729912371ff82622874cde18bfda99f905322a9fa16d3e52d0d973d17d4b2da5c92d93ada3eadd19f9f90db57bdddfa2b03cbeb12aff7d
+EBUILD gnote-3.30.0.ebuild 1608 BLAKE2B ae94df56146ca758d6bd06b52acde7d38b4a956ad8fbe90970ba1085471ddf0e587583336c09b20db7552fd9a19b19848d13e9d5203c9d7a4a8bfd1f7a0a78f2 SHA512 23fd26fcee15af1cbbce35b3dacafd0990a6e42d478c7b870e985511a301c5f312fbaab10b45b91a81e8362ac7885aafdbe990fa69da54b3d2b00bed234c5760
MISC metadata.xml 342 BLAKE2B 51d98560833845aa6d1f2b9f4c85021fd317434efcd81ba31d106c7b4945acd23cfefc2de2a601ffef3d330adcf93ec0377f69107fa37771d80f7dff056d32ff SHA512 c68c058e279222cc9293a5b97fbf450f95a940a70a32b1adcac3e6276783d2bcc545f39895e92e7bd62c9ac5dc98139dc9800513c2a828895ba1fcf023227d21
diff --git a/app-misc/gnote/gnote-3.30.0.ebuild b/app-misc/gnote/gnote-3.30.0.ebuild
new file mode 100644
index 000000000000..c5ce78a1cb5c
--- /dev/null
+++ b/app-misc/gnote/gnote-3.30.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# Automagic:
+# glib-2.32 dep
+# >=dev-libs/unittest++-1.5.1 (but not detected due to missing .pc)
+# glibmm: first version in tree providing Thread API fix
+COMMON_DEPEND="
+ >=app-crypt/libsecret-0.8
+ >=app-text/gtkspell-3.0:3
+ >=dev-cpp/glibmm-2.52.1-r1:2
+ >=dev-cpp/gtkmm-3.18:3.0
+ >=dev-libs/glib-2.32:2[dbus]
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16:=
+ >=x11-libs/gtk+-3.20:3
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+DEPEND="${DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.35.0
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not alter CFLAGS
+ sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die
+
+ gnome2_src_prepare
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}