summaryrefslogtreecommitdiff
path: root/app-misc/gnuit/gnuit-4.9.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/gnuit/gnuit-4.9.5-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/gnuit/gnuit-4.9.5-r2.ebuild')
-rw-r--r--app-misc/gnuit/gnuit-4.9.5-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/gnuit/gnuit-4.9.5-r2.ebuild b/app-misc/gnuit/gnuit-4.9.5-r2.ebuild
new file mode 100644
index 000000000000..3f949e51f693
--- /dev/null
+++ b/app-misc/gnuit/gnuit-4.9.5-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="GNU Interactive Tools - increase speed and efficiency of most daily tasks"
+HOMEPAGE="https://www.gnu.org/software/gnuit/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.3"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format-security.patch
+}
+
+src_configure() {
+ # The transition option controls whether a "git" wrapper is installed, it is
+ # disabled explicitly so we don't need to block on dev-vcs/git.
+ econf --disable-transition
+}
+
+src_install() {
+ default
+ #emake DESTDIR="${D}" htmldir="/usr/share/doc/${PF}/html" install
+ mv "${D}/usr/bin/gitview" "${D}/usr/bin/gnuitview" || die
+}
+
+pkg_postinst() {
+ elog "The 'git' tool this package previously installed is now called 'gitfm'"
+ elog "The 'gitview' tool this package previously installed is now called 'gnuitview'"
+ elog "If you want the 'gitaction' tool to use your preferred desktop"
+ elog "application settings install the 'x11-misc/xdg-utils' package."
+}