summaryrefslogtreecommitdiff
path: root/app-misc/golly/golly-2.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/golly/golly-2.7-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/golly/golly-2.7-r1.ebuild')
-rw-r--r--app-misc/golly/golly-2.7-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-misc/golly/golly-2.7-r1.ebuild b/app-misc/golly/golly-2.7-r1.ebuild
new file mode 100644
index 000000000000..b07bc8262aab
--- /dev/null
+++ b/app-misc/golly/golly-2.7-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+WX_GTK_VER=3.0
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1 gnome2-utils wxwidgets
+
+DESCRIPTION="simulator for Conway's Game of Life and other cellular automata"
+HOMEPAGE="http://golly.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="dev-lang/perl
+ sys-libs/zlib
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}"
+
+S=${WORKDIR}/${P}-src
+ECONF_SOURCE=gui-wx/configure
+
+src_configure() {
+ econf --with-perl-shlib="libperl.so"
+}
+
+src_install() {
+ emake docdir= DESTDIR="${D}" install
+ dodoc docs/ReadMe.html
+ newicon --size 32 gui-wx/icons/appicon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Golly" ${PN} "Science"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}