summaryrefslogtreecommitdiff
path: root/app-misc/goobook
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/goobook
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/goobook')
-rw-r--r--app-misc/goobook/Manifest5
-rw-r--r--app-misc/goobook/goobook-1.9.ebuild48
-rw-r--r--app-misc/goobook/metadata.xml16
3 files changed, 69 insertions, 0 deletions
diff --git a/app-misc/goobook/Manifest b/app-misc/goobook/Manifest
new file mode 100644
index 000000000000..9a76d73145d6
--- /dev/null
+++ b/app-misc/goobook/Manifest
@@ -0,0 +1,5 @@
+DIST goobook-1.9.tar.gz 29274 SHA256 311cb344d285e8af36dcd4546d3bd499939140287a12b2d509ea6f2535c2b50b SHA512 66d017bfa0fcad39d24b80e454d4d2e97f92a95f6dbf545739b89721b8c44702177a7f656d9cf1f38ac8278f235935afe666047cbfb64733f8deae6838f91d81 WHIRLPOOL 64d79136a126a19baec327de8cee928d4db025b06ad9364954efbe3cc5e9712f0c1539a57bcd73000f989027c46acfff05ddd75db228eade568c9ded189f3f52
+EBUILD goobook-1.9.ebuild 1287 SHA256 68f41eadd0fb29af19d278ed9cc3abc321ea2aaa850846f31e45fbc380d7399b SHA512 9c3245db9df02db1a2620a6ac9f62ea4825d98399e89b49d28391e58e98c11e59c523c5a800be6f06b64d86cd64d2a35e75780ecc0a4fab8a2ef9b143541427a WHIRLPOOL e646f877e9737f1691cda2163174f16d7bfc0a65ab9d0e6136c94691cfcd24d2b12a96f6c2284f506a5969f54e31479f6ab1deb1ba9ab3391dcfbdfcb5b983d0
+MISC ChangeLog 2634 SHA256 b7eb57ad751b69c7a85e001639d6c3ad805f3560543d32cedc2e01d6da9b5d99 SHA512 10af49c61fad350575e8b49fcdba068ee4535307faa9d1cb30328567185131c4096c0dd4f2ddaf33c05ce754b0f3e00b6c66ad56f8ee52ec08c0fd2211dad62a WHIRLPOOL ad107bc10d12a6e39c60416f8d371a704c12d2a1620975fc6aab09bd21228a3f571479f6be30e5170530d4ddae00172af736e33d06124253b6b33fc93fe93b37
+MISC ChangeLog-2015 2269 SHA256 90d4dea656d59edebf4bf6e612b4931808bc95d92f5a78548ceed8b7cfef3918 SHA512 fcffaa1618f86c5169cde493df57531038f5ba1bb57bc891a2944cce600a2f2286495a063337c4c27397777679450d823c2aee9cf6bca91686ed248b8a2fa4d9 WHIRLPOOL 50f43ba075aa562dbec955e08a5edff763d28fabbc0caa46f8d03ec00024fc1e9082fe55beca0a2161ab56a6882ffc074ba745eb7f5d623d3def899d51e00c24
+MISC metadata.xml 511 SHA256 cd3c0085f3414bc06a75de8f0ba2410dbe81561c8d6f0ddbeaed586c4ffd53d8 SHA512 0dc6124705876f166ce360bf80e3d125067717d9b5ed326b0a831a86f0f77afaef31da9a0e4aaba025916287b27c9a4a0a8f226474839ee6fa0e5bfde1030459 WHIRLPOOL 86d812f41d1887a9c4c6cb00322960e12ab03de46d3b45f25c5570d2f149d384b5daf413ed7d5c713d13e8fb082c8a43fc0598bce20ab126a5d87f1e60fb797e
diff --git a/app-misc/goobook/goobook-1.9.ebuild b/app-misc/goobook/goobook-1.9.ebuild
new file mode 100644
index 000000000000..bc1386f33d80
--- /dev/null
+++ b/app-misc/goobook/goobook-1.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 readme.gentoo
+
+DESCRIPTION="Google Contacts wrapper for mutt"
+HOMEPAGE="https://gitlab.com/goobook/goobook"
+SRC_URI="mirror://pypi/g/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/gdata-2.0.7[${PYTHON_USEDEP}]
+ >=dev-python/hcs-utils-1.3[${PYTHON_USEDEP}]
+ >=dev-python/keyring-0.2[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/oauth2client-1.4.11[${PYTHON_USEDEP}]"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ readme.gentoo_create_doc
+}
+
+FORCE_PRINT_ELOG=1 # remove in the next bump
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="
+To setup initial authentication, execute:
+
+~ $ goobook authenticate
+
+If you want to use goobook from mutt, add this in your .muttrc file:
+ set query_command=\"goobook query '%s'\"
+to query address book.
+
+You may find more information and advanced configuration tips at
+https://pypi.python.org/pypi/${PN}/${PV} in \"Configure/Mutt\" section"
diff --git a/app-misc/goobook/metadata.xml b/app-misc/goobook/metadata.xml
new file mode 100644
index 000000000000..43780dd0d6f2
--- /dev/null
+++ b/app-misc/goobook/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>fabiano.francesconi@gmail.com</email>
+ <name>Fabiano Francesconi</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">goobook</remote-id>
+ </upstream>
+</pkgmetadata>