summaryrefslogtreecommitdiff
path: root/app-misc/gourmet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/gourmet
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/gourmet')
-rw-r--r--app-misc/gourmet/Manifest6
-rw-r--r--app-misc/gourmet/files/gourmet-0.17.4-pyglet.patch56
-rw-r--r--app-misc/gourmet/files/no-docs-0.17.0.patch10
-rw-r--r--app-misc/gourmet/files/tostring-to-tobytes.patch26
-rw-r--r--app-misc/gourmet/gourmet-0.17.4-r2.ebuild62
-rw-r--r--app-misc/gourmet/metadata.xml48
6 files changed, 208 insertions, 0 deletions
diff --git a/app-misc/gourmet/Manifest b/app-misc/gourmet/Manifest
new file mode 100644
index 000000000000..77a7bbc4fc1b
--- /dev/null
+++ b/app-misc/gourmet/Manifest
@@ -0,0 +1,6 @@
+AUX gourmet-0.17.4-pyglet.patch 1664 BLAKE2B 1d995fab691dffcb654bb6da7960cb66340a1b3ad72d3caaaba957b04a39d41b5215df2318d2727332c537c35a4d1839471c288fdfea6d0d84bca9a9644d23fd SHA512 162b6b80b09326b15a1cbc8e045ba1fea36bfc106a6f1182659c890e0c100c0820b4f42f24f154be2f8fe2f457e212ace9c989002f33ea26523b1000b888c66e
+AUX no-docs-0.17.0.patch 338 BLAKE2B fae9f389c8ea29c275ac917358a572d2b7aabb98f114cf2a69a7ab84e9be8de501114ea0d471181bba8dbfce77768654f179ee9cbe34b3db14dc4a3823e535df SHA512 0e8f3c35411ee7f895490762acca7da2eff6e498de6c35511c90c2dd91dc6872f405b8a73465dd411eb193cbf0c8a37b75a5dd06e89e8601e268bffbe6f674ba
+AUX tostring-to-tobytes.patch 988 BLAKE2B 05dad2fbf164fa5cc13bcdb831bd05444829c712fa3930a0221a3b47ee21e2c32ae30858d2d06b84f20ba3d7764c402605ce89496c6c5b5d33078eed1f3fdd77 SHA512 72b12c9e775bea34ce82c53a8e808fd212eec523f03ca591735ee90121cc45ec6a6464168fe16d66c9889e92168accf8643b0486bc53ef8d144aa92070f3f94c
+DIST gourmet-0.17.4.tar.gz 8487830 BLAKE2B 511da1ae85a788fdce622cb9eb1822e6f264daffc76f25ceb8148de0a4658d9a2307278e6e981073d1aed0fa6e96d543386ed7357e0c9a3c1b511bd107dee62d SHA512 54010a5527f33e08b38d0fdf143cc4528e8ccc65ccad3253074135212751c3bc4385ba5f721327268f455bf85ff6f248e56ebfa1b98933a4ee061983eb9daa4e
+EBUILD gourmet-0.17.4-r2.ebuild 2312 BLAKE2B 817f9e8f3b3cc8609eba941a3406b7ee4dfd8e3ee789337cb36fe1b6d14c734d0f20243d32d4dded941f3e7c8c9502ad6cd10431411c66ed4889d455c36a1e99 SHA512 4163adbc0a8d7142a4779855d920f238f6870d2b94f3142b09b0f99bcf22108ebbd8c0161c808eaef6ad63d9d1ed858ed8a300d1b29a1b2a81b17ad91ff0a04c
+MISC metadata.xml 1559 BLAKE2B 827915e778b988f9e264492d1f499254fcdf5f4403804396a3a7dd79cf9b4fe527f53208d67a56fe720223434e8044b16118cc4969bb530ad2295f687941ef7b SHA512 67cb0b91052e1a2b0cd917839f796435cd45fe157e69d1ac8fbad7a3f4e09176db9f8d217edf0dd032cdc5b20a1e1c2ab3c56e57ddb8e291f55e5a1ff27764bf
diff --git a/app-misc/gourmet/files/gourmet-0.17.4-pyglet.patch b/app-misc/gourmet/files/gourmet-0.17.4-pyglet.patch
new file mode 100644
index 000000000000..1547cde8f00d
--- /dev/null
+++ b/app-misc/gourmet/files/gourmet-0.17.4-pyglet.patch
@@ -0,0 +1,56 @@
+diff --git a/gourmet/sound.py b/gourmet/sound.py
+index 2dea6bb7..c232d258 100644
+--- a/gourmet/sound.py
++++ b/gourmet/sound.py
+@@ -1,15 +1,19 @@
+ try:
+- from sound_gst import Player
++ from sound_pyglet import Player
+ except ImportError:
+- print 'No gst player'
++ print 'No pyglet player'
+ try:
+- from sound_windows import Player
++ from sound_gst import Player
+ except ImportError:
+- print 'No windows player'
+- import sys
+- class Player:
+- """Fallback player"""
+- def play_file (self,path):
+- print 'No player installed -- beeping instead'
+- for n in range(5): sys.stdout.write('\a'); sys.stdout.flush()
++ print 'No gst player'
++ try:
++ from sound_windows import Player
++ except ImportError:
++ print 'No windows player'
++ import sys
++ class Player:
++ """Fallback player"""
++ def play_file (self,path):
++ print 'No player installed -- beeping instead'
++ for n in range(5): sys.stdout.write('\a'); sys.stdout.flush()
+
+diff --git a/gourmet/sound_pyglet.py b/gourmet/sound_pyglet.py
+new file mode 100644
+index 00000000..41da613a
+--- /dev/null
++++ b/gourmet/sound_pyglet.py
+@@ -0,0 +1,16 @@
++import pyglet
++
++class Player:
++ def __init__ (self):
++ pass
++
++ def play_file (self,path):
++ self.source = pyglet.media.load(path,streaming=False)
++ self.source.play()
++
++ def stop_play (self,path):
++ pass
++
++if __name__ == '__main__':
++ p = Player()
++ p.play_file('../data/sound/phone.wav')
diff --git a/app-misc/gourmet/files/no-docs-0.17.0.patch b/app-misc/gourmet/files/no-docs-0.17.0.patch
new file mode 100644
index 000000000000..9002a2ef3384
--- /dev/null
+++ b/app-misc/gourmet/files/no-docs-0.17.0.patch
@@ -0,0 +1,10 @@
+--- setup.py 2014-03-02 14:56:56.090600468 -0500
++++ setup.py 2014-03-02 14:57:00.184465687 -0500
+@@ -141,7 +141,6 @@
+
+ files.extend(data_files)
+ files.extend([(os.path.join(base,'ui'), glob.glob(os.path.join('ui','*.ui')))])
+- files.extend([(os.path.join('share','doc','gourmet'), ['FAQ', 'LICENSE'])])
+
+ return files
+
diff --git a/app-misc/gourmet/files/tostring-to-tobytes.patch b/app-misc/gourmet/files/tostring-to-tobytes.patch
new file mode 100644
index 000000000000..e42c59403d51
--- /dev/null
+++ b/app-misc/gourmet/files/tostring-to-tobytes.patch
@@ -0,0 +1,26 @@
+diff --git a/gourmet/gtk_extras/ratingWidget.py b/gourmet/gtk_extras/ratingWidget.py
+index 0e01735..efa6463 100644
+--- a/gourmet/gtk_extras/ratingWidget.py
++++ b/gourmet/gtk_extras/ratingWidget.py
+@@ -135,7 +135,7 @@ class StarGenerator:
+ if is_rgba: rowstride = 4
+ else: rowstride = 3
+ pb=gtk.gdk.pixbuf_new_from_data(
+- image.tostring(),
++ image.tobytes(),
+ gtk.gdk.COLORSPACE_RGB,
+ is_rgba,
+ 8,
+diff --git a/gourmet/plugins/browse_recipes/icon_helpers.py b/gourmet/plugins/browse_recipes/icon_helpers.py
+index 61c772c..2e7b08b 100644
+--- a/gourmet/plugins/browse_recipes/icon_helpers.py
++++ b/gourmet/plugins/browse_recipes/icon_helpers.py
+@@ -38,7 +38,7 @@ def get_pixbuf_from_image (image):
+ if is_rgba: rowstride = 4
+ else: rowstride = 3
+ pb=gtk.gdk.pixbuf_new_from_data(
+- image.tostring(),
++ image.tobytes(),
+ gtk.gdk.COLORSPACE_RGB,
+ is_rgba,
+ 8,
diff --git a/app-misc/gourmet/gourmet-0.17.4-r2.ebuild b/app-misc/gourmet/gourmet-0.17.4-r2.ebuild
new file mode 100644
index 000000000000..0e0dd28ffa97
--- /dev/null
+++ b/app-misc/gourmet/gourmet-0.17.4-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Recipe Organizer and Shopping List Generator for Gnome"
+HOMEPAGE="https://thinkle.github.com/gourmet/"
+SRC_URI="https://github.com/thinkle/gourmet/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="-i18n -ipython pdf print spell sound web"
+
+RDEPEND=">=dev-python/pygtk-2.22.0:2[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.7.9-r1[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ i18n? ( dev-python/elib-intl[${PYTHON_USEDEP}] )
+ ipython? ( >=dev-python/ipython-0.13.2[${PYTHON_USEDEP}] )
+ pdf? (
+ >=dev-python/reportlab-2.6[${PYTHON_USEDEP}]
+ >=dev-python/python-poppler-0.12.1-r4[${PYTHON_USEDEP}]
+ )
+ print? (
+ >=dev-python/reportlab-2.6[${PYTHON_USEDEP}]
+ >=dev-python/python-poppler-0.12.1-r4[${PYTHON_USEDEP}]
+ )
+ spell? ( >=dev-python/gtkspell-python-2.25.3-r1[${PYTHON_USEDEP}] )
+ sound? ( dev-python/pyglet[${PYTHON_USEDEP}] )
+ web? ( >=dev-python/beautifulsoup-3.2.1-r1:python-2[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ >=dev-python/python-distutils-extra-2.37-r1[${PYTHON_USEDEP}]"
+
+PATCHES=( ${FILESDIR}/no-docs-0.17.0.patch \
+ ${FILESDIR}/tostring-to-tobytes.patch \
+ ${FILESDIR}/${PN}-${PV}-pyglet.patch )
+DOCS=( ChangeLog CODING.md FAQ README.md TESTS TODO.md )
+
+python_prepare_all() {
+ # Modify these lines before copying them out
+ sed -i "s:base_dir = '..':base_dir = '/usr/share':" gourmet/settings.py || die
+ sed -i 's:data_dir = os.path.join(base_dir, "gourmet", "data"):data_dir = os.path.join(base_dir, "gourmet"):' gourmet/settings.py || die
+ sed -i 's:\(icon_base = os.path.join(data_dir,\) "icons",:\1 "gourmet",:' gourmet/settings.py || die
+ sed -i 's:\(locale_base = os.path.join(base_dir, "gourmet",\) "build",:\1:' gourmet/settings.py || die
+ sed -i 's:\(plugin_base = os.path.join(base_dir,\) "gourmet", "build", "share",:\1:' gourmet/settings.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_prepare() {
+ distutils-r1_python_prepare
+ sed -i "s:\(lib_dir = \)'../gourmet':\1'$(python_get_sitedir)':" gourmet/settings.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman gourmet.1
+}
diff --git a/app-misc/gourmet/metadata.xml b/app-misc/gourmet/metadata.xml
new file mode 100644
index 000000000000..90652c4bf09f
--- /dev/null
+++ b/app-misc/gourmet/metadata.xml
@@ -0,0 +1,48 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>nixphoeni@gentoo.org</email>
+ <name>Joe Sapp</name>
+ </maintainer>
+ <longdescription>
+ Gourmet Recipe Manager is an application to store, organize
+ and search recipes. Gourmet also makes it easy to create
+ shopping lists from recipes. Gourmet imports recipes from a
+ number of sources, including MealMaster and MasterCook
+ archives and several popular websites. Gourmet can export
+ recipes as text, MealMaster files, HTML web pages, PDF, and
+ a custom XML format for exchange with other Gourmet users.
+ Gourmet supports linking images with recipes.
+ </longdescription>
+ <upstream>
+ <maintainer>
+ <email>Thomas_Hinkle@alumni.brown.edu</email>
+ <name>Thomas Mills Hinkle</name>
+ </maintainer>
+ <maintainer>
+ <email>ockham@raz.or.at</email>
+ <name>Bernhard Reiter</name>
+ </maintainer>
+ <bugs-to>https://github.com/thinkle/gourmet/issues</bugs-to>
+ <remote-id type="github">thinkle/gourmet</remote-id>
+ </upstream>
+ <use>
+ <flag name="i18n">
+ Enable support for i18n through elib.intl
+ </flag>
+ <flag name="ipython">
+ Enable support for the interactive Python console plugin
+ </flag>
+ <flag name="pdf">Enable export to PDF</flag>
+ <flag name="print">
+ Enable pretty Python printing
+ </flag>
+ <flag name="spell">
+ Enable support for the spell check plugin
+ </flag>
+ <flag name="web">
+ Enable support for the web import plugin
+ </flag>
+ </use>
+</pkgmetadata>