summaryrefslogtreecommitdiff
path: root/app-misc/gramps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /app-misc/gramps
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'app-misc/gramps')
-rw-r--r--app-misc/gramps/Manifest2
-rw-r--r--app-misc/gramps/gramps-5.1.2-r1.ebuild24
2 files changed, 19 insertions, 7 deletions
diff --git a/app-misc/gramps/Manifest b/app-misc/gramps/Manifest
index 90bf4ce9b33b..2923564d0f85 100644
--- a/app-misc/gramps/Manifest
+++ b/app-misc/gramps/Manifest
@@ -1,3 +1,3 @@
DIST gramps-5.1.2.tar.gz 17304294 BLAKE2B 5d253f59e8312b5438922bcc00cce10368b75e45170d3b2f83be4b6226cb734dfd6e90bcde506aea9a572592f5f156aa0a1b977736df90b3eaff9bda3d592690 SHA512 12e88645d14717823457308cba55e1f6899e2a6aebcf281875261765f163529fd75512fca034db59816473c6542319166375bec6d5502e8e6a7c452bfc10c0ad
-EBUILD gramps-5.1.2-r1.ebuild 2054 BLAKE2B c5ae8154cc93b82ba0ed477833a02444ce55b524a58bb3218757eb62cc9b9aa609a3c94e97f995dcfd0eccc538d8dd1ec822d3794b7ee956f9e9e772c4e5581e SHA512 88e0155ff411b12a89f179181450d1ab9020f8a7cf24accd95f9d5606b64dd83b3ff653367ce3d1bea38912c14bef918d04dcf8d339bfc8e9caa840e834d76ab
+EBUILD gramps-5.1.2-r1.ebuild 2323 BLAKE2B b237c48264b0a5c6f539571b266b79c1927d38b7732a3b0629422d170a5b04d2f53117accc943ee488d5ae3302c09f003a8c48be3d1615df7e1ad01835a0f7b2 SHA512 3ae328cc32a25f906ef43cd792b668b92a18c4395c5b1ed60d90b0b535142c3edf0b27f69f47e5b90910c49d4b874c84211fea4d7bf296c48b8d8f6b01f6f5d0
MISC metadata.xml 5598 BLAKE2B 4516bb11bb4fa57403d9b86409a073021dc9372b4d6d53af2c90cb31d5988b960ce4ab9f190b7e82948c1118f1fb0581bef1f8e1e4bbc9da8c294541eabbeda5 SHA512 74b37ffecc01f6c140f349d822ceedf20eb36af2c7a09faca53abaacede12d916cae4b514d066026600bd46d04943c4948dda7fe8c85e7e01714ebd24e428359
diff --git a/app-misc/gramps/gramps-5.1.2-r1.ebuild b/app-misc/gramps/gramps-5.1.2-r1.ebuild
index b05f6a7ce789..86a7c50dab9e 100644
--- a/app-misc/gramps/gramps-5.1.2-r1.ebuild
+++ b/app-misc/gramps/gramps-5.1.2-r1.ebuild
@@ -2,10 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="sqlite"
DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1 xdg-utils
DESCRIPTION="Genealogical Research and Analysis Management Programming System"
@@ -20,11 +21,11 @@ IUSE="+rcs +reports exif geo postscript spell"
RDEPEND="
$(python_gen_cond_dep '
- dev-python/bsddb3[${PYTHON_MULTI_USEDEP}]
- dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
- >=dev-python/pygobject-3.12:3[cairo,${PYTHON_MULTI_USEDEP}]
- dev-python/pyicu[${PYTHON_MULTI_USEDEP}]
- exif? ( >=media-libs/gexiv2-0.5[${PYTHON_MULTI_USEDEP},introspection] )
+ dev-python/bsddb3[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.12:3[cairo,${PYTHON_USEDEP}]
+ dev-python/pyicu[${PYTHON_USEDEP}]
+ exif? ( >=media-libs/gexiv2-0.5[${PYTHON_USEDEP},introspection] )
')
gnome-base/librsvg:2
>x11-libs/gtk+-3.14.8:3[introspection]
@@ -62,6 +63,17 @@ python_test_all() {
esetup.py test
}
+# Ugly hack to work around Bug #717922
+python_install() {
+ local mydistutilsargs=(
+ --resourcepath=/usr/share
+ --no-compress-manpages
+ build
+ )
+ distutils-r1_python_install
+ echo -n "/usr/share" > "${D}$(python_get_sitedir)/gramps/gen/utils/resource-path" || die
+}
+
pkg_postinst() {
xdg_desktop_database_update
xdg_mimeinfo_database_update