summaryrefslogtreecommitdiff
path: root/app-misc/hexcompare
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/hexcompare
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/hexcompare')
-rw-r--r--app-misc/hexcompare/Manifest4
-rw-r--r--app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch14
-rw-r--r--app-misc/hexcompare/hexcompare-1.0.4.ebuild28
-rw-r--r--app-misc/hexcompare/metadata.xml11
4 files changed, 57 insertions, 0 deletions
diff --git a/app-misc/hexcompare/Manifest b/app-misc/hexcompare/Manifest
new file mode 100644
index 000000000000..6d2f17f351ef
--- /dev/null
+++ b/app-misc/hexcompare/Manifest
@@ -0,0 +1,4 @@
+AUX hexcompare-1.0.4-Makefile.patch 445 BLAKE2B 68b34176c976109a2c9b7cc17b88b92f877f2f05784bc726907ae2c28b4923d8f0649fd3fefa987e04c0b996ac2da1ab4789f90162c4eed7b3db3b70add229df SHA512 8f66e5b080d41906ea9301c066a51f5869a7274e29a6a1391ea81d129dfc88682f035c1ab57319199d5e82020fac7e96e2666fec362a5605d562dc5826448a4b
+DIST hexcompare-1.0.4.tar.gz 9686 BLAKE2B 930004101504ec2bce1aaadac03a221e29e4668cf58591292510d3c66effbdd5f91fc405fc4d55d9116ec3ba260c91927371c8768e01ccf4169cb6d955642128 SHA512 847bf7e26f27aa0ff56e38b3fe95ad7940a0226e0c496963530fa405d8a3a50f8288a4c7f28d48d4cce05e52c1f69180917a7f10da0943cabf977f78b62eb5fe
+EBUILD hexcompare-1.0.4.ebuild 533 BLAKE2B d937143767bad3cefbf91c9533bf4411b6202b9372a335e230e2f99070597031fdeaa3051cb0ce460ae97e40bd2c2277e297bf6636e62bcbbc762b5c72deeb7d SHA512 3718883457b7dc577392c254d7d4345aee25c0a56e33051383247a40b01f0da8adccea3ce3802f20398f8362ad5154ab615c76a5456365f3f366ac57d628d181
+MISC metadata.xml 323 BLAKE2B 043e136d1f7ba694b012de967d34b7959235ec42f11149c294320b04845571561178755f523105b030c0fcdec143372fde63abbfe7093d8cdd53aabb790123a9 SHA512 ed9c5371824dbf3b0954b16809a85ef0ad9646c0c6342fefa778450f15e6bb092050e0384c3fc05d1a68b4f4430f2bddc5d9ce09ada00728172c1aa5674d0c25
diff --git a/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch b/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch
new file mode 100644
index 000000000000..5ccef2047bc7
--- /dev/null
+++ b/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch
@@ -0,0 +1,14 @@
+--- hexcompare-1.0.4/Makefile
++++ hexcompare-1.0.4/Makefile
+@@ -1,9 +1,9 @@
+-CFLAGS = -O3 -Wall -Wextra -pedantic -Wformat-security -std=gnu89
++CFLAGS += -Wall -Wextra -pedantic -Wformat-security -std=gnu89
+
+ all: hexcompare
+
+ hexcompare: main.c gui.c
+- $(CC) $(CFLAGS) -o hexcompare main.c gui.c -lncurses
++ $(CC) $(CFLAGS) `pkg-config --cflags ncurses` -o hexcompare main.c gui.c `pkg-config --libs ncurses`
+
+ clean:
+ rm -f *.o
diff --git a/app-misc/hexcompare/hexcompare-1.0.4.ebuild b/app-misc/hexcompare/hexcompare-1.0.4.ebuild
new file mode 100644
index 000000000000..7b11bccd5ad8
--- /dev/null
+++ b/app-misc/hexcompare/hexcompare-1.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="ncurses-based visual comparison of binary files"
+HOMEPAGE="http://hexcompare.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}
diff --git a/app-misc/hexcompare/metadata.xml b/app-misc/hexcompare/metadata.xml
new file mode 100644
index 000000000000..fc00942f6391
--- /dev/null
+++ b/app-misc/hexcompare/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">hexcompare</remote-id>
+ </upstream>
+</pkgmetadata>