summaryrefslogtreecommitdiff
path: root/app-misc/hivex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-08 04:26:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-08 04:26:34 +0100
commit325837835fc86686829aaa6acace3d3c06c74cea (patch)
tree6cc31680e4ce26ab26e863fd7b72d0ffe2d9366f /app-misc/hivex
parent7ad61ca2bfc8f8da08d2fb3085e4333dcccb0a64 (diff)
gentoo auto-resync : 08:10:2024 - 04:26:34
Diffstat (limited to 'app-misc/hivex')
-rw-r--r--app-misc/hivex/Manifest2
-rw-r--r--app-misc/hivex/hivex-1.3.24.ebuild165
2 files changed, 167 insertions, 0 deletions
diff --git a/app-misc/hivex/Manifest b/app-misc/hivex/Manifest
index b1047b2f2d34..eb1ac7f15126 100644
--- a/app-misc/hivex/Manifest
+++ b/app-misc/hivex/Manifest
@@ -1,3 +1,5 @@
DIST hivex-1.3.23.tar.gz 738076 BLAKE2B b536e1b4b930b88b4bbbf8a4434e5ed7d407409acdbe68f7da67fa8198e1813bf84e918505eca7d341f15b41daeb0bbcfc974868a68f999e26941db759557fd5 SHA512 068fe81a442c8045bf9d98f0c6b782330141d8f1e104a0f191c04a2cff25ee6396c2c4777c107d595a471eb4bcbee903400c9f7946cae036165ac201587f861e
+DIST hivex-1.3.24.tar.gz 741279 BLAKE2B 9f4a7d66db75a8636bca9b818bcbd57fc82e1dabb324c3a087cba4bd16b3e8c97afe8b9208f409e1759615d7ac0f811c1b1764a2dc7ed04f30208587e3598206 SHA512 4b9be259e0359344aee2dce1e4df56d928b0e429abcc099479ba95b2940fb80cd285f22e6a914902bcc716e8b4b528f204bea10977913fc701ae45aacb66669b
EBUILD hivex-1.3.23-r1.ebuild 2820 BLAKE2B 4a351f13696f05523f83ceb13892842f58a384e65212de06f7583d852d351fd2d6d7ac79601bd9139d6a42757e00b28eca39ae295270b37d0d20b8204f994536 SHA512 a4c9ee5eccab861e9b5706f4bd5ece1bc709acea7aa61c351ab82e70314775e77b845fe57d24787b891e6c61b60dce0c6b2a3de8f6dfdd65826b5f00890d12ec
+EBUILD hivex-1.3.24.ebuild 2789 BLAKE2B 38d6bf12437b03ad83c27b9befb4ed27a8d8bbfdae965041cbc154c6da3e24e986a11bb1c3d4e87918249fa1fc2c474df1b6a35fd9370b290b647cb08a5bbb64 SHA512 63ed3aceda2bfdc28535aa871be28915a00507e5b6d7779b20691df23a74f9d2fed2d670dcc89edd2789a51e24f3d8910faf5302b6604a9fbe24ad75b0b6f609
MISC metadata.xml 249 BLAKE2B 6f4e10a8e257d2bb0d3eb8396ec0a4cf29d381ab118c8ef082dff01403cd79db12de157a1e35f0823aead216efcdcf7eab982cf326ad0fe149e9e0cabc205159 SHA512 b32d21b3e68e122d51c5c344f88095410c2b7e9cba5714579c087a2348bb45b0cb542abfec0f6902b205a60e045595c9ab5474694c1ea4bbb0610d4c5a89867f
diff --git a/app-misc/hivex/hivex-1.3.24.ebuild b/app-misc/hivex/hivex-1.3.24.ebuild
new file mode 100644
index 000000000000..fa123690b8b4
--- /dev/null
+++ b/app-misc/hivex/hivex-1.3.24.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby32"
+RUBY_OPTIONAL=yes
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit perl-module ruby-ng python-single-r1 strip-linguas
+
+DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
+HOMEPAGE="https://libguestfs.org"
+SRC_URI="https://libguestfs.org/download/${PN}/${P}.tar.gz"
+S="${WORKDIR}/${P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="ocaml +perl python readline ruby test"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ virtual/libiconv
+ virtual/libintl
+ ocaml? (
+ dev-lang/ocaml[ocamlopt]
+ dev-ml/findlib[ocamlopt]
+ )
+ perl? (
+ dev-lang/perl:=
+ dev-perl/IO-stringy
+ )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:= )
+ ruby? ( $(ruby_implementations_depend) )
+"
+DEPEND="
+ ${RDEPEND}
+ perl? (
+ test? (
+ dev-perl/Pod-Coverage
+ dev-perl/Test-Pod-Coverage
+ )
+ )
+"
+
+ruby_add_bdepend "
+ ruby? (
+ dev-ruby/rake
+ dev-ruby/rdoc
+ virtual/rubygems
+ )
+"
+ruby_add_rdepend "ruby? ( virtual/rubygems )"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ ruby? ( || ( $(ruby_get_use_targets) ) )
+"
+
+DOCS=( README )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ use ruby && ruby-ng_pkg_setup
+}
+
+src_unpack() {
+ default
+
+ cp -prlP "${WORKDIR}/${P}" "${WORKDIR}"/all || die
+}
+
+src_prepare() {
+ default
+
+ use perl && perl-module_src_prepare
+ use ruby && ruby-ng_src_prepare
+}
+
+src_configure() {
+ use ruby && ruby-ng_src_configure
+
+ if use perl; then
+ pushd perl || die
+ perl-module_src_configure
+ popd || die
+ fi
+
+ local myeconfargs=(
+ --enable-nls
+ --disable-ruby
+ --disable-rpath
+ $(use_with readline)
+ $(use_enable ocaml)
+ $(use_enable perl)
+ $(use_enable python)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+each_ruby_configure() {
+ local myeconfargs=(
+ --without-readline
+ --disable-ocaml
+ --disable-perl
+ --enable-nls
+ --enable-ruby
+ --disable-python
+ --disable-rpath
+ )
+
+ export ac_cv_prog_RUBY="${RUBY}"
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ use ruby && ruby-ng_src_compile
+}
+
+each_ruby_compile() {
+ # -C ruby deliberately omitted as we need the library itself built too
+ emake
+}
+
+src_test() {
+ emake check
+
+ local dir
+ for dir in ocaml perl python ; do
+ use ${dir} && emake -C ${dir} check
+ done
+}
+
+each_ruby_test() {
+ emake -C ruby check
+}
+
+src_install() {
+ strip-linguas -i po
+
+ emake install DESTDIR="${ED}" "LINGUAS=""${LINGUAS}"""
+
+ use python && python_optimize
+ use ruby && ruby-ng_src_install
+
+ if use perl; then
+ perl_delete_localpod
+
+ # Workaround Build.PL for now (see libguestfs too)
+ doman "${ED}"/usr/man/man3/*
+ rm -r "${ED}"/usr/man || die
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+each_ruby_install() {
+ emake -C ruby install DESTDIR="${ED}"
+}