summaryrefslogtreecommitdiff
path: root/app-misc/hivex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /app-misc/hivex
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'app-misc/hivex')
-rw-r--r--app-misc/hivex/Manifest2
-rw-r--r--app-misc/hivex/hivex-1.3.18.ebuild110
2 files changed, 112 insertions, 0 deletions
diff --git a/app-misc/hivex/Manifest b/app-misc/hivex/Manifest
index fe93c97ebc7a..7011dc8f9410 100644
--- a/app-misc/hivex/Manifest
+++ b/app-misc/hivex/Manifest
@@ -1,3 +1,5 @@
DIST hivex-1.3.14.tar.gz 1332257 BLAKE2B fe7c19e05d29c7e98a334842cc1144aa76b148a3b7aae91449a4923a124eb54227a9a004346ef3558732c688c4f92cacd0c9328056930c33dba0404465634da0 SHA512 dd7dd52dceda580179a815fc48a2a2c7e8f7234614beceb937fba7e317df17984e65453338160c4c467b70d7d4f9bd61b48aad3ca51e19bd5e4cfbca8ee3adb6
+DIST hivex-1.3.18.tar.gz 1542133 BLAKE2B 961d0797770a2bd3176ce288a509fab8685de91317d55f05e5295f9f56fd54c31acb64847e0cbb6a6074627ccbdfdf35bd0d35150beb7746a8b3de9128ac24e3 SHA512 1851351118921e81df9e505f90d00048a178572c2edd3de40194a69915176bdb615e2eb5afea408d57063e98257c8d1e3d0cd6730407153892cc9e3befc4aa3a
EBUILD hivex-1.3.14.ebuild 1849 BLAKE2B 0c138e91aba7d4bdd04680d34330123cba162564f1ccc70d8310d77de7ab87940bd3bc87f65a84a2585a194cafc821538a9674c2ec32eb45f001c7895c26d432 SHA512 0c25e80c4a57e7fdaec743ab7696149f68541468569d2f46353dc2c16e9441270108ebd5238b38cb96d25f1d74eda56b3afb0d9636200edd730b6df5f8a5d97a
+EBUILD hivex-1.3.18.ebuild 2012 BLAKE2B f09323eb98b587a7511553a20436af5c319f944fee81ebc27081635ada7b19946c47c17e36d59860947594b61d39d7a476ec8b628585a9a05752daa528109f11 SHA512 b09471c6d176fdd527d07aed7d901a73875081ad4ca8d385a165aa8e01deabb805e3a783b4f453b981d1ddbc52ec5562c5a290dadf565edc36d183c33b87bd7a
MISC metadata.xml 245 BLAKE2B 5599732e8923ea2b90a26adcb5708b6cf95cd3db28e810b9f881ac7d0e2c63745609f4c6e21708bdda7792f769df77bfa4b9d4d135eda71831efcaaab122c384 SHA512 1c6cdb75d4cbbd8d3a5f2cc24950924c030db330e135cf2cacecdaaa99ee65117efd7abd9f8652bf5dfa8169d427f51ff84123aab11fa8ef82498a6834b0805a
diff --git a/app-misc/hivex/hivex-1.3.18.ebuild b/app-misc/hivex/hivex-1.3.18.ebuild
new file mode 100644
index 000000000000..ac1bd5848abb
--- /dev/null
+++ b/app-misc/hivex/hivex-1.3.18.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby23 ruby24 ruby25"
+RUBY_OPTIONAL=yes
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit eutils perl-module ruby-ng python-single-r1
+
+DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
+HOMEPAGE="http://libguestfs.org"
+SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ocaml readline +perl python test static-libs ruby"
+
+RDEPEND="
+ virtual/libiconv
+ virtual/libintl
+ dev-libs/libxml2:2
+ ocaml? ( dev-lang/ocaml[ocamlopt]
+ dev-ml/findlib[ocamlopt]
+ )
+ readline? ( sys-libs/readline:0 )
+ perl? (
+ dev-lang/perl:=
+ dev-perl/IO-stringy
+ )
+ ruby? ( $(ruby_implementations_depend) )
+ python? ( ${PYTHON_DEPS} )
+ "
+
+DEPEND="${RDEPEND}
+ perl? (
+ test? ( dev-perl/Pod-Coverage
+ dev-perl/Test-Pod-Coverage )
+ )
+ "
+
+ruby_add_bdepend "ruby? ( dev-ruby/rake
+ virtual/rubygems
+ dev-ruby/rdoc )"
+ruby_add_rdepend "ruby? ( virtual/rubygems )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ ruby? ( || ( $(ruby_get_use_targets) ) )"
+
+DOCS=( README )
+
+S="${WORKDIR}/${P}"
+
+pkg_setup() {
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_unpack() {
+ default
+ cp -prlP "${WORKDIR}/${P}" "${WORKDIR}"/all
+}
+
+src_configure() {
+ ruby-ng_src_configure
+
+ if use perl; then
+ pushd perl
+ perl-module_src_configure
+ popd
+ fi
+
+ local myeconfargs=(
+ $(use_with readline)
+ $(use_enable ocaml)
+ $(use_enable perl)
+ --enable-nls
+ --disable-ruby
+ $(use_enable python)
+ --disable-rpath
+ )
+
+ econf ${myeconfargs[@]}
+}
+
+src_compile() {
+ default
+ ruby-ng_src_compile
+}
+
+src_install() {
+ strip-linguas -i po
+
+ emake install DESTDIR="${ED}" "LINGUAS=""${LINGUAS}"""
+ python_optimize
+
+ ruby-ng_src_install
+
+ if use perl; then
+ perl_delete_localpod
+ fi
+
+ #can't figure out a better way to do this
+ mv "${ED}"/usr/man/man3/* "${ED}/usr/share/man/man3/" || die
+ rm -r "${ED}/usr/man" || die
+}