summaryrefslogtreecommitdiff
path: root/app-misc/imgurbash2/imgurbash2-3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /app-misc/imgurbash2/imgurbash2-3.2.ebuild
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'app-misc/imgurbash2/imgurbash2-3.2.ebuild')
-rw-r--r--app-misc/imgurbash2/imgurbash2-3.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/imgurbash2/imgurbash2-3.2.ebuild b/app-misc/imgurbash2/imgurbash2-3.2.ebuild
new file mode 100644
index 000000000000..c47b35c320b3
--- /dev/null
+++ b/app-misc/imgurbash2/imgurbash2-3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ram-on/imgurbash2.git"
+else
+ SRC_URI="https://github.com/ram-on/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Bash script that uploads/deletes images to/from imgur"
+HOMEPAGE="https://github.com/ram-on/imgurbash2"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="X wayland"
+
+RDEPEND="
+ net-misc/curl
+ wayland? ( gui-apps/wl-clipboard )
+ X? ( || ( x11-misc/xclip x11-misc/xsel ) )
+"
+
+src_install() {
+ einstalldocs
+ dobin imgurbash2
+}