summaryrefslogtreecommitdiff
path: root/app-misc/jdupes/jdupes-1.21.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-25 22:29:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-25 22:29:02 +0100
commit240b57012ace855bbfd9934b07642416ceeeb5b8 (patch)
treef73ef3c4e5df8a1c5ca8d47177cb034006e0ac09 /app-misc/jdupes/jdupes-1.21.3.ebuild
parent5c636a121a9064a4373d06b60d49a6f5d67c0e2f (diff)
gentoo auto-resync : 25:07:2023 - 22:29:01
Diffstat (limited to 'app-misc/jdupes/jdupes-1.21.3.ebuild')
-rw-r--r--app-misc/jdupes/jdupes-1.21.3.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/app-misc/jdupes/jdupes-1.21.3.ebuild b/app-misc/jdupes/jdupes-1.21.3.ebuild
deleted file mode 100644
index 73f625b27e25..000000000000
--- a/app-misc/jdupes/jdupes-1.21.3.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="Identify duplicate files on the filesystem"
-HOMEPAGE="https://github.com/jbruchon/jdupes"
-if [[ "${PV}" == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/jbruchon/jdupes.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/jbruchon/jdupes/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64"
-fi
-LICENSE="MIT"
-SLOT="0"
-
-IUSE="+dedupe lowmem hardened"
-
-# missing test.sh script
-# https://github.com/jbruchon/jdupes/issues/191
-RESTRICT="test"
-
-src_prepare() {
- sed -i -e '/PREFIX/s/=/?=/' Makefile || die
- default
-}
-
-src_compile() {
- tc-export CC
- local myconf=(
- $(usex dedupe 'ENABLE_DEDUPE=1' '')
- $(usex lowmem 'LOW_MEMORY=1' '')
- $(usex hardened 'HARDEN=1' '')
- )
- emake ${myconf[@]}
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
- einstalldocs
-}