summaryrefslogtreecommitdiff
path: root/app-misc/khal/khal-0.10.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-18 07:56:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-18 07:56:02 +0100
commiteb17cef883968037fcc6177549d44a030f08b69c (patch)
tree50c47314ceabb3efe7efeb72edeecca54b2aa905 /app-misc/khal/khal-0.10.5.ebuild
parent5fa0e0c7e62842b1491426c8c6e506f51b6c78e1 (diff)
gentoo auto-resync : 18:10:2022 - 07:56:02
Diffstat (limited to 'app-misc/khal/khal-0.10.5.ebuild')
-rw-r--r--app-misc/khal/khal-0.10.5.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/khal/khal-0.10.5.ebuild b/app-misc/khal/khal-0.10.5.ebuild
new file mode 100644
index 000000000000..07c83a85bd60
--- /dev/null
+++ b/app-misc/khal/khal-0.10.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A CalDAV based calendar"
+HOMEPAGE="https://lostpackets.de/khal/ https://github.com/pimutils/khal"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-log[${PYTHON_USEDEP}]
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/vdirsyncer[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+"
+
+DOCS=( AUTHORS.txt CHANGELOG.rst CONTRIBUTING.rst README.rst khal.conf.sample )
+
+distutils_enable_tests pytest