summaryrefslogtreecommitdiff
path: root/app-misc/livecd-tools/livecd-tools-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/livecd-tools/livecd-tools-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/livecd-tools/livecd-tools-9999.ebuild')
-rw-r--r--app-misc/livecd-tools/livecd-tools-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/livecd-tools/livecd-tools-9999.ebuild b/app-misc/livecd-tools/livecd-tools-9999.ebuild
new file mode 100644
index 000000000000..99000ce942c3
--- /dev/null
+++ b/app-misc/livecd-tools/livecd-tools-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/livecd-tools.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~williamh/dist/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+inherit eutils
+
+DESCRIPTION="Gentoo LiveCD tools for autoconfiguration of hardware"
+HOMEPAGE="https://www.gentoo.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND="
+ >=sys-apps/baselayout-2
+ >=sys-apps/openrc-0.8.2-r1
+ dev-util/dialog
+ net-dialup/mingetty
+ sys-apps/gawk
+ sys-apps/pciutils
+ sys-apps/sed
+"
+
+pkg_setup() {
+ ewarn "This package is designed for use on the LiveCD only and will do"
+ ewarn "unspeakably horrible and unexpected things on a normal system."
+ ewarn "YOU HAVE BEEN WARNED!!!"
+}
+
+src_install() {
+ doconfd conf.d/*
+ doinitd init.d/*
+ dosbin net-setup
+ into /
+ dosbin livecd-functions.sh
+}