summaryrefslogtreecommitdiff
path: root/app-misc/mtail
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/mtail
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/mtail')
-rw-r--r--app-misc/mtail/Manifest5
-rw-r--r--app-misc/mtail/files/mtail-1.1.1-remove-blanks.patch52
-rw-r--r--app-misc/mtail/metadata.xml15
-rw-r--r--app-misc/mtail/mtail-1.1.1-r3.ebuild30
4 files changed, 102 insertions, 0 deletions
diff --git a/app-misc/mtail/Manifest b/app-misc/mtail/Manifest
new file mode 100644
index 000000000000..cc50fe8539c6
--- /dev/null
+++ b/app-misc/mtail/Manifest
@@ -0,0 +1,5 @@
+AUX mtail-1.1.1-remove-blanks.patch 1850 BLAKE2B dfaffe1b7dbbe54c1db30a7e0ce9c3c50f51397d5c8dc1e5a64d32441907593e58e65ca84d5697043509342a99d86d628f131cfbe7d0617a207b30afc0b177bb SHA512 64720ec0253dfc88e58b0392bcb4c1eb2f367547d034f60722dc19b0093d5da3d40e847c69203080cd19126ab67f7fad3c2dccc7e6cc74f56c1d50f3dee805a4
+DIST mtail-1.1.1.tgz 9124 BLAKE2B 804ec168eb5dc5408ffd91fc80a6f080b0575dfb58bc667a3ff3d657cea955a4a697ff3f99470e86e59387e0bb2275cd2a0a6e5ee97bc88f28df4424a4c012b8 SHA512 987816ce5d12996192c881be1ac5a28c3457757e981ab35e657fb226c3980a22091c9fc85f68c13eb1c01939e08e492814b6a03c9b1f4f4bc1878c4f13ec8a0e
+DIST mtailrc-syslog.sample 1785 BLAKE2B d060e9baf750505a0908bb18533aad72675962be98875e9f1fed3c734a0339589122ebe2774cc585b05dfde61d8877e05a42184c966050e245bb57ed2dfe500b SHA512 d6bbaafa7c599f443c788697087ebef69a8e279b0715fa4e5b770531cbd254a646014fa98e5e5d444c48d23974201d36a856b34507a91e1b6abbb423f7015c75
+EBUILD mtail-1.1.1-r3.ebuild 774 BLAKE2B d0db274c93f5d5b29ba4364da797bcbc6c84e4f1e8d9cb383333b4b9690c22c4bdc82464f618f663aceb1a633d03a7df75d01f563fc72ba9b50838b6403c5bd5 SHA512 71ac79bf2bdb32e2a2f3111797c261053fd2a11211376bc7ed554e49bc7b6582a727f240af1565884949aaacf570da623694ecedf68e3ae5e93024e8befd39d0
+MISC metadata.xml 642 BLAKE2B 405817cdcf7d643b775f88848ad91930dcf712d65f5c53582ac41656f7d92095bed83add109070888134c074118c54d7ff79359a20d97d0e1459095923e12185 SHA512 7de4bfd79c4dbd929950e191faf4ff6ab90426a0f604fddbdcbaf65d21d21d9a5ec7fb382dc95751ccda8e463bd189dbc07b4d29d92c9dab90e7eb955ace8e19
diff --git a/app-misc/mtail/files/mtail-1.1.1-remove-blanks.patch b/app-misc/mtail/files/mtail-1.1.1-remove-blanks.patch
new file mode 100644
index 000000000000..9645e263deda
--- /dev/null
+++ b/app-misc/mtail/files/mtail-1.1.1-remove-blanks.patch
@@ -0,0 +1,52 @@
+--- mtail.orig 2003-11-07 19:02:34.000000000 +0000
++++ mtail 2003-11-07 19:19:18.000000000 +0000
+@@ -46,6 +46,7 @@
+ verbose = 0
+ silent = 0
+ active = 0
++remove_blanks = 0
+
+ # sets up the interrupt handler, calls processargs(), sets up and starts the
+ # tailers.
+@@ -119,6 +120,8 @@
+ if line[len(line)-1] == '\n':
+ line = line[:len(line)-1]
+ line = filter(line)
++ if remove_blanks and not line:
++ continue
+ lock.acquire()
+ try:
+ if (multiple or verbose) and (not silent) \
+@@ -138,12 +141,14 @@
+ global verbose
+ global silent
+ global config_file
++ global remove_blanks
+ filenames = []
+ lines = None
+ follow = 0
+ try:
+ opts, pargs = getopt.getopt(sys.argv[1:], 'fn:?hvq', ["follow",
+- "lines=", "help", "verbose", "quiet", "silent", "config="])
++ "lines=", "help", "verbose", "quiet", "silent", "config=",
++ "remove-blanks"])
+ except getopt.error:
+ print 'unrecognized option!'
+ print
+@@ -163,6 +168,8 @@
+ silent = 1
+ elif opt[0] in ['--config']:
+ config_file = opt[1]
++ elif opt[0] in ['--remove-blanks']:
++ remove_blanks = 1
+ if lines == None:
+ lines = 10
+ for filename in pargs:
+@@ -186,6 +193,7 @@
+ print ' -v, --verbose always output headers giving file names'
+ print ' -q, --quiet, --silent never output headers giving file names'
+ print ' --config=FILE use config file FILE instead of ~/.mtailrc'
++ print ' --remove-blanks do not display blank lines'
+ print
+ print 'with more than one filename, mtail will precede each chunk from'
+ print 'each with a header giving the file name. if no filenames are given'
diff --git a/app-misc/mtail/metadata.xml b/app-misc/mtail/metadata.xml
new file mode 100644
index 000000000000..1215b29430c5
--- /dev/null
+++ b/app-misc/mtail/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ mtail is a small tail workalike that performs output coloring using
+ ansi escape sequences (although the sequences are overridable, so you
+ could cause it to output something else, e.g. html font tags, if you
+ really wanted to). mtail is written in python, is fairly small, and
+ should be relatively platform-independent.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-misc/mtail/mtail-1.1.1-r3.ebuild b/app-misc/mtail/mtail-1.1.1-r3.ebuild
new file mode 100644
index 000000000000..1ab1926f586f
--- /dev/null
+++ b/app-misc/mtail/mtail-1.1.1-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1
+
+DESCRIPTION="Tail workalike, that performs output colourising"
+HOMEPAGE="http://matt.immute.net/src/mtail/"
+SRC_URI="http://matt.immute.net/src/mtail/mtail-${PV}.tgz
+ http://matt.immute.net/src/mtail/mtailrc-syslog.sample"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="alpha amd64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND=${PYTHON_DEPS}
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-remove-blanks.patch
+ python_fix_shebang .
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc CHANGES "${PN}rc.sample" README "${DISTDIR}"/mtailrc-syslog.sample || die
+}