summaryrefslogtreecommitdiff
path: root/app-misc/mvcase/mvcase-0.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-01 03:14:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-01 03:14:33 +0100
commit0c764edfecb7e9e124d4669acd98bed09e23b6c0 (patch)
tree2862ab17d2f88cb7c9614b7fbe579f25ae604b8d /app-misc/mvcase/mvcase-0.1-r3.ebuild
parentae1bf373db295b495e1f685d116e3411bf10df0b (diff)
gentoo auto-resync : 01:08:2022 - 03:14:32
Diffstat (limited to 'app-misc/mvcase/mvcase-0.1-r3.ebuild')
-rw-r--r--app-misc/mvcase/mvcase-0.1-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/mvcase/mvcase-0.1-r3.ebuild b/app-misc/mvcase/mvcase-0.1-r3.ebuild
new file mode 100644
index 000000000000..866c9116d34c
--- /dev/null
+++ b/app-misc/mvcase/mvcase-0.1-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A modified version of mv, used to convert filenames to lower/upper case"
+HOMEPAGE="https://www.ibiblio.org/pub/Linux/utils/file"
+SRC_URI="https://www.ibiblio.org/pub/Linux/utils/file/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="dev-libs/shhopt"
+RDEPEND="${DEPEND}"
+BDEPEND="sys-apps/groff"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-includes.patch
+ "${FILESDIR}"/${P}-flags.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin mvcase
+ doman mvcase.1
+}