summaryrefslogtreecommitdiff
path: root/app-misc/ondir
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/ondir
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/ondir')
-rw-r--r--app-misc/ondir/Manifest5
-rw-r--r--app-misc/ondir/metadata.xml8
-rw-r--r--app-misc/ondir/ondir-0.2.2-r2.ebuild45
-rw-r--r--app-misc/ondir/ondir-0.2.4.ebuild44
4 files changed, 102 insertions, 0 deletions
diff --git a/app-misc/ondir/Manifest b/app-misc/ondir/Manifest
new file mode 100644
index 000000000000..bfb9fd8c5606
--- /dev/null
+++ b/app-misc/ondir/Manifest
@@ -0,0 +1,5 @@
+DIST ondir-0.2.2.tar.gz 20138 BLAKE2B 3724b8d356cec16e1f60ec49574e2f688d4f7456f48f1d909402e8436f588d9617c827eda9a74c1b930d2538fe8c9d1372a1d222124d8f7b863bf8e895cfaa25 SHA512 5c2c53532934b25d2a170c619d067c369b6acf2ef3e0a87607619613dcc0bbfc570937fb91cdc5df3f22ae0453b5a5d00edd57cd1b852f7a076c15b96c45d4dd
+DIST ondir-0.2.4.tar.gz 52860 BLAKE2B e9111f9a64d8d7393d9a8e48d5dc66d5814995ae1dbd2f577538a03021c1b1b92af43acbd0ab9cb24ab29ba16c50d5752a9442689effc62bd8c13b6fe11a4785 SHA512 f59a823807f86ce2992aaf5fb174ddea222b02ed18e1289ca450179bd090892f1467072dfcec97ce219e216c055781ea7a1a05bb9402276fb9404a57f42ddb52
+EBUILD ondir-0.2.2-r2.ebuild 983 BLAKE2B 1ad1bf96ffea8060f6a676183d5c200165e928cbf46e5a4ddc2dfdd342e150c53bc9375a8413fae34a2a0af147a34ab1cac6caa19b3858e0ae33e85bbeb4e8b6 SHA512 4da1bcf80437796ea0c427f3be610c406880ff76e2d59c651078ab86917c3a06ad3e1b5b017836d499a7cd3ad1095ea9a5308def391764c78dc042063b1af7fe
+EBUILD ondir-0.2.4.ebuild 936 BLAKE2B eaaf969c2efa62b1f186c2101ea597f22ec5d5a0731500615468238ea21a25ead29baf87e113d022380404c0082da32305eb77c5c36bef30c7e0871cc6eae8d7 SHA512 b76a67250437ff8cf6014502bec594bff0e3aeea9ea14b472e7c09bb02f2a8c2b595cd5e3a870cde4b63f15263a1c3a74b4620ce18402f96993a03cc8b30bc31
+MISC metadata.xml 265 BLAKE2B 75452ad720a31a08fc0dcd02eec704c18b11bc0660686f9a320b85fc879f55a564ce9c3b6a8c710781b74c5e8eb3d0544c02a042fb35a0b62a5e1491f675296a SHA512 176f814d8c555e8726f36e012367b698e8a19a0662982621029a7f9190beecc5e6798e43c51698dc149364966cdeff7061121e54fa9d4cf2a3559a6ce4904e25
diff --git a/app-misc/ondir/metadata.xml b/app-misc/ondir/metadata.xml
new file mode 100644
index 000000000000..3cf14bf74636
--- /dev/null
+++ b/app-misc/ondir/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-misc/ondir/ondir-0.2.2-r2.ebuild b/app-misc/ondir/ondir-0.2.2-r2.ebuild
new file mode 100644
index 000000000000..59d6874ad10e
--- /dev/null
+++ b/app-misc/ondir/ondir-0.2.2-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Automatically execute scripts as you traverse directories"
+HOMEPAGE="http://swapoff.org/OnDir"
+SRC_URI="http://swapoff.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+DEPEND="sys-apps/sed"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README INSTALL scripts.tcsh scripts.sh )
+HTML_DOCS=( changelog.html ondir.1.html )
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:\(/man/.*$\):/share\1:g" \
+ -e "s:-g:${CFLAGS}:" Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ PREFIX="${EPREFIX}/usr" \
+ CONF="${EPREFIX}/etc/ondirrc" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ default
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ CONF="${EPREFIX}/etc/ondirrc" \
+ install
+ newdoc ondirrc.eg ondirrc.example
+}
diff --git a/app-misc/ondir/ondir-0.2.4.ebuild b/app-misc/ondir/ondir-0.2.4.ebuild
new file mode 100644
index 000000000000..2f51ec18dee6
--- /dev/null
+++ b/app-misc/ondir/ondir-0.2.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Automatically execute scripts as you traverse directories"
+HOMEPAGE="http://swapoff.org/OnDir"
+SRC_URI="http://swapoff.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+DEPEND="sys-apps/sed"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog INSTALL scripts.tcsh scripts.sh )
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:\(/man/.*$\):/share\1:g" \
+ -e "s:-g:${CFLAGS}:" Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ PREFIX="${EPREFIX}/usr" \
+ CONF="${EPREFIX}/etc/ondirrc" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ default
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ CONF="${EPREFIX}/etc/ondirrc" \
+ install
+ newdoc ondirrc.eg ondirrc.example
+}