summaryrefslogtreecommitdiff
path: root/app-misc/ondir
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-26 20:10:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-26 20:10:49 +0000
commitc85a90f90521c7e11d618b527d6630cc64cecbd4 (patch)
tree27c1f04d8eab0e0140fb62887a6a5d4d87c32ad9 /app-misc/ondir
parent2f51c9978dda4c6e8debca43e4235ecc86914032 (diff)
gentoo resync : 26.12.2017
Diffstat (limited to 'app-misc/ondir')
-rw-r--r--app-misc/ondir/Manifest1
-rw-r--r--app-misc/ondir/ondir-0.2.2-r2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-misc/ondir/Manifest b/app-misc/ondir/Manifest
index b177bf4f620f..3eeb44f9ae7d 100644
--- a/app-misc/ondir/Manifest
+++ b/app-misc/ondir/Manifest
@@ -1,3 +1,4 @@
DIST ondir-0.2.2.tar.gz 20138 BLAKE2B 3724b8d356cec16e1f60ec49574e2f688d4f7456f48f1d909402e8436f588d9617c827eda9a74c1b930d2538fe8c9d1372a1d222124d8f7b863bf8e895cfaa25 SHA512 5c2c53532934b25d2a170c619d067c369b6acf2ef3e0a87607619613dcc0bbfc570937fb91cdc5df3f22ae0453b5a5d00edd57cd1b852f7a076c15b96c45d4dd
EBUILD ondir-0.2.2-r1.ebuild 975 BLAKE2B 5d9074434ac4b378ead3345a37e2b481a8367d8764d2bf8664c7fa3fbd3c818fee9397d36c4edb9a7682aa68d40e3f2dbc7965ad03efe5fb51bb4d571277da5f SHA512 48e3830ad786995a135ecbdf4023bff87778c82f025965789bfcb6d645a3f8445beaeaab3b74a0a0d43ee8b711e3b4d0823c42257cd7c486d773e9298f141013
+EBUILD ondir-0.2.2-r2.ebuild 986 BLAKE2B dff0fdca5cd268b720551b73ce0941f58cfc01024d3a031f1a6bbeecf60b786338bb985645a1143040adb16f15f63cff6f3121a13c0205bef32e736457bba0cc SHA512 c88c2072211afb448140b6b252c7626502d2516e902b22f71692c8db00318f7154879d4f86313dec2c18866073c4028b5fbf02f3ecb86ec946834c846793e145
MISC metadata.xml 265 BLAKE2B 75452ad720a31a08fc0dcd02eec704c18b11bc0660686f9a320b85fc879f55a564ce9c3b6a8c710781b74c5e8eb3d0544c02a042fb35a0b62a5e1491f675296a SHA512 176f814d8c555e8726f36e012367b698e8a19a0662982621029a7f9190beecc5e6798e43c51698dc149364966cdeff7061121e54fa9d4cf2a3559a6ce4904e25
diff --git a/app-misc/ondir/ondir-0.2.2-r2.ebuild b/app-misc/ondir/ondir-0.2.2-r2.ebuild
new file mode 100644
index 000000000000..d483901c75fa
--- /dev/null
+++ b/app-misc/ondir/ondir-0.2.2-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Automatically execute scripts as you traverse directories"
+HOMEPAGE="http://swapoff.org/OnDir"
+SRC_URI="http://swapoff.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+DEPEND="sys-apps/sed"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README INSTALL scripts.tcsh scripts.sh )
+HTML_DOCS=( changelog.html ondir.1.html )
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:\(/man/.*$\):/share\1:g" \
+ -e "s:-g:${CFLAGS}:" Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ PREFIX="${EPREFIX}/usr" \
+ CONF="${EPREFIX}/etc/ondirrc" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ default
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ CONF="${EPREFIX}/etc/ondirrc" \
+ install
+ newdoc ondirrc.eg ondirrc.example
+}