summaryrefslogtreecommitdiff
path: root/app-misc/openastro/openastro-1.1.56.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /app-misc/openastro/openastro-1.1.56.ebuild
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'app-misc/openastro/openastro-1.1.56.ebuild')
-rw-r--r--app-misc/openastro/openastro-1.1.56.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/openastro/openastro-1.1.56.ebuild b/app-misc/openastro/openastro-1.1.56.ebuild
new file mode 100644
index 000000000000..1a0a8770f703
--- /dev/null
+++ b/app-misc/openastro/openastro-1.1.56.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_5 python3_6 )
+
+inherit distutils-r1
+
+MY_PN=${PN}.org
+
+DESCRIPTION="A fully-featured Open Source Astrology Program"
+HOMEPAGE="http://openastro.org"
+SRC_URI="http://ppa.launchpad.net/pellesimon/ubuntu/pool/main/o/${MY_PN}/${MY_PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="jpeg png"
+
+DEPEND="
+ app-misc/openastro-data[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pycairo[svg(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyswisseph[${PYTHON_USEDEP}]
+ gnome-base/librsvg:2[introspection]
+ x11-libs/gtk+:3[introspection]"
+RDEPEND="${DEPEND}
+ jpeg? ( media-gfx/imagemagick[jpeg,svg] )
+ png? ( media-gfx/imagemagick[png,svg] )"
+
+S=${WORKDIR}/${MY_PN}-${PV}