summaryrefslogtreecommitdiff
path: root/app-misc/openastro
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/openastro
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/openastro')
-rw-r--r--app-misc/openastro/Manifest3
-rw-r--r--app-misc/openastro/metadata.xml16
-rw-r--r--app-misc/openastro/openastro-1.1.56.ebuild34
3 files changed, 53 insertions, 0 deletions
diff --git a/app-misc/openastro/Manifest b/app-misc/openastro/Manifest
new file mode 100644
index 000000000000..60abbd6db30f
--- /dev/null
+++ b/app-misc/openastro/Manifest
@@ -0,0 +1,3 @@
+DIST openastro.org_1.1.56.orig.tar.gz 212271 BLAKE2B d0252ae7f3c4c4f255ab1e402f3491b2b61e295f2d2064bd6a25ba07424526cbba01f2fe9f255eced0037b4d05edd1b0cde2e0fdae5c0fd7849652d5f8bfb1c7 SHA512 0446575bde71ca5bc88177bf1d5b8088cd1bb8e29ecfbd83ff15ebc4da4f07534c987f8a00b555a0af85c613e5d6bd2cec60898b586110c2230570446e4b7f2d
+EBUILD openastro-1.1.56.ebuild 919 BLAKE2B 21726da473e1e56e06512ba566d1457fd4a5f73efc8d073bbecbcdb25eeb7e505ccfe7da7d50dacbefa32d3d3b161029cccc8c41760788a4ea54be6b2edfcb84 SHA512 684758d970d7515c5f82a8f137fa805376103221167f067584efacc42f57c157c996d255e3759a2910e1244d71b3d8bcfd0385f9888d7a1d7d04dbe4328c4ad4
+MISC metadata.xml 554 BLAKE2B b7e8a99695365047f82469d977834081f033f7742a56a376897455e1b87acbf305454088dc9102265747b67f327733a74386e2d0e04c2f8c6d521ad44bd40bee SHA512 4c226c8e6dc6effd387a8fd9af0c1f52b471e90c4fdca04d37b291fae787eaa7d390bca12c0a5095bc2a242ba32daf80005ac69ea48e3764a0685b1974c88301
diff --git a/app-misc/openastro/metadata.xml b/app-misc/openastro/metadata.xml
new file mode 100644
index 000000000000..8ee7525f685c
--- /dev/null
+++ b/app-misc/openastro/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <maintainer status="active">
+ <email>devel@openastro.org</email>
+ <name>Pelle van der Scheer</name>
+ </maintainer>
+ <bugs-to>https://bugs.launchpad.net/openastro.org</bugs-to>
+ </upstream>
+ <use>
+ <flag name="jpeg">Enable exporting Astrological Charts to jpeg</flag>
+ <flag name="png">Enable exporting Astrological Charts to png</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-misc/openastro/openastro-1.1.56.ebuild b/app-misc/openastro/openastro-1.1.56.ebuild
new file mode 100644
index 000000000000..1a0a8770f703
--- /dev/null
+++ b/app-misc/openastro/openastro-1.1.56.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_5 python3_6 )
+
+inherit distutils-r1
+
+MY_PN=${PN}.org
+
+DESCRIPTION="A fully-featured Open Source Astrology Program"
+HOMEPAGE="http://openastro.org"
+SRC_URI="http://ppa.launchpad.net/pellesimon/ubuntu/pool/main/o/${MY_PN}/${MY_PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="jpeg png"
+
+DEPEND="
+ app-misc/openastro-data[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pycairo[svg(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyswisseph[${PYTHON_USEDEP}]
+ gnome-base/librsvg:2[introspection]
+ x11-libs/gtk+:3[introspection]"
+RDEPEND="${DEPEND}
+ jpeg? ( media-gfx/imagemagick[jpeg,svg] )
+ png? ( media-gfx/imagemagick[png,svg] )"
+
+S=${WORKDIR}/${MY_PN}-${PV}