summaryrefslogtreecommitdiff
path: root/app-misc/openrgb-plugin-effects
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /app-misc/openrgb-plugin-effects
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'app-misc/openrgb-plugin-effects')
-rw-r--r--app-misc/openrgb-plugin-effects/Manifest3
-rw-r--r--app-misc/openrgb-plugin-effects/metadata.xml15
-rw-r--r--app-misc/openrgb-plugin-effects/openrgb-plugin-effects-0_p20210619.ebuild47
3 files changed, 65 insertions, 0 deletions
diff --git a/app-misc/openrgb-plugin-effects/Manifest b/app-misc/openrgb-plugin-effects/Manifest
new file mode 100644
index 000000000000..5404dfffc17d
--- /dev/null
+++ b/app-misc/openrgb-plugin-effects/Manifest
@@ -0,0 +1,3 @@
+DIST OpenRGBEffectsPlugin-a8ea7eef586d9dc341fbe67f60cb8cb4d69a9504.tar.bz2 345726 BLAKE2B e8cf741ba935521c449d3b2a326a44b709c919cb3e3694cbd07939205b8f589dcc00b46cdb1f08684e4e4d3d0a798aade7c051ebc16c3c82368fbeb94ec84fb5 SHA512 134b46090386f94fcf77c4a0a1807ac94ecb8323f318e01098a1edf9b3cf555dbc7f1c5abce484dd4aba9cea32ae7aac5abc0f5f1d26e8edee4afe197f5a254f
+EBUILD openrgb-plugin-effects-0_p20210619.ebuild 1216 BLAKE2B 5e6bdd46fea196d181de40601f62b8ffe212962e8d605b437bcef37e5a8d596531656a632dafaef10f662c33e1e173f425087fb17fa1156a32896b9b1561ab22 SHA512 21edaed69de8d6454fb182d34f24a6ddf5b4831e0f3f5c07b358063fb8e79fd3867285a89823aa45688e6a3cd0a33f5b5295d65098d08f84b0b31fb952f6e280
+MISC metadata.xml 483 BLAKE2B 8a331ab87feb1fe11fe4a5d9e0d7657685d858182c847e3ef3d647f2b0f4f0f31de36c4fba307a1a9ca09ba82fc8aba9a6a887fe2669b453fa7b96e82d54ec57 SHA512 304f23af3f70c7ae7c7221bf53cc991e160711bc7160d7d6082388b457cf88c06851b66963537580fd15c60d63cf0787722b1f63f16c4679d47fc8ef173469f2
diff --git a/app-misc/openrgb-plugin-effects/metadata.xml b/app-misc/openrgb-plugin-effects/metadata.xml
new file mode 100644
index 000000000000..6a2173ad1876
--- /dev/null
+++ b/app-misc/openrgb-plugin-effects/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>alexey+gentoo@asokolov.org</email>
+ <name>Alexey Sokolov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">OpenRGBDevelopers/OpenRGBEffectsPlugin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/openrgb-plugin-effects/openrgb-plugin-effects-0_p20210619.ebuild b/app-misc/openrgb-plugin-effects/openrgb-plugin-effects-0_p20210619.ebuild
new file mode 100644
index 000000000000..3bf56003dd4d
--- /dev/null
+++ b/app-misc/openrgb-plugin-effects/openrgb-plugin-effects-0_p20210619.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+MY_GIT_COMMIT="a8ea7eef586d9dc341fbe67f60cb8cb4d69a9504"
+SRC_URI="https://gitlab.com/OpenRGBDevelopers/OpenRGBEffectsPlugin/-/archive/${MY_GIT_COMMIT}/OpenRGBEffectsPlugin-${MY_GIT_COMMIT}.tar.bz2"
+S="${WORKDIR}/OpenRGBEffectsPlugin-${MY_GIT_COMMIT}"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Plugin for OpenRGB with various Effects that can be synced across devices"
+HOMEPAGE="https://gitlab.com/OpenRGBDevelopers/OpenRGBEffectsPlugin"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=app-misc/openrgb-0.6-r1:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-libs/openal
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/nlohmann_json
+"
+
+src_prepare() {
+ default
+ rm -r OpenRGB || die
+}
+
+src_configure() {
+ eqmake5 \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann" \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/OpenRGB" \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/OpenRGB/RGBController" \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/OpenRGB/i2c_smbus" \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/OpenRGB/net_port"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/OpenRGB/plugins
+ doexe libOpenRGBEffectsPlugin.so.1.0
+}