summaryrefslogtreecommitdiff
path: root/app-misc/qcma/qcma-0.4.2_pre20181227-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-29 02:14:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-29 02:14:02 +0000
commita493ba7d75043e8e649ee8d6d4942c1f4b31d1c5 (patch)
treed9aef2725cb8f60bd6f5a47afa9778eb94114793 /app-misc/qcma/qcma-0.4.2_pre20181227-r2.ebuild
parentd7ef5a07f47da6898dcb2d1503790c59b0470571 (diff)
gentoo auto-resync : 29:12:2022 - 02:14:02
Diffstat (limited to 'app-misc/qcma/qcma-0.4.2_pre20181227-r2.ebuild')
-rw-r--r--app-misc/qcma/qcma-0.4.2_pre20181227-r2.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/app-misc/qcma/qcma-0.4.2_pre20181227-r2.ebuild b/app-misc/qcma/qcma-0.4.2_pre20181227-r2.ebuild
index d294019b2044..bd1e2fe321dc 100644
--- a/app-misc/qcma/qcma-0.4.2_pre20181227-r2.ebuild
+++ b/app-misc/qcma/qcma-0.4.2_pre20181227-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit qmake-utils vcs-snapshot
+inherit qmake-utils vcs-snapshot xdg-utils
GIT_COMMIT="65f0eab8ca0640447d2e84cdc5fadc66d2c07efb"
@@ -53,3 +53,15 @@ src_install() {
insinto /usr/share/${PN}/translations
doins common/resources/translations/${PN}_*.qm
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}