summaryrefslogtreecommitdiff
path: root/app-misc/regex-markup/regex-markup-0.10.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/regex-markup/regex-markup-0.10.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/regex-markup/regex-markup-0.10.0-r1.ebuild')
-rw-r--r--app-misc/regex-markup/regex-markup-0.10.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/regex-markup/regex-markup-0.10.0-r1.ebuild b/app-misc/regex-markup/regex-markup-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..042bcb70aa2d
--- /dev/null
+++ b/app-misc/regex-markup/regex-markup-0.10.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="A tool to color syslog files as well"
+HOMEPAGE="http://www.nongnu.org/regex-markup/"
+SRC_URI="https://savannah.nongnu.org/download/regex-markup/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="examples nls"
+
+PATCHES=(
+ "${FILESDIR}/${P}-locale.patch"
+)
+
+src_configure() {
+ # fix #570960 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+
+ econf \
+ --enable-largefile \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ if use examples; then
+ cd examples || die
+ emake -f Makefile
+ fi
+}