summaryrefslogtreecommitdiff
path: root/app-misc/resolve-march-native/resolve-march-native-4.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-02 16:58:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-02 16:58:13 +0000
commitd602f48b0029adc0d2ad1fceed902419909e98ac (patch)
tree83eed23327b538798d7aff4633914e0af5cc78e9 /app-misc/resolve-march-native/resolve-march-native-4.0.0.ebuild
parent4c506c69909bdb43fda5e36c79b165e404d3b86b (diff)
gentoo auto-resync : 02:12:2023 - 16:58:12
Diffstat (limited to 'app-misc/resolve-march-native/resolve-march-native-4.0.0.ebuild')
-rw-r--r--app-misc/resolve-march-native/resolve-march-native-4.0.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-misc/resolve-march-native/resolve-march-native-4.0.0.ebuild b/app-misc/resolve-march-native/resolve-march-native-4.0.0.ebuild
new file mode 100644
index 000000000000..aafd9d6b010f
--- /dev/null
+++ b/app-misc/resolve-march-native/resolve-march-native-4.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Resolve GCC flag -march=native"
+HOMEPAGE="https://github.com/hartwork/resolve-march-native"
+SRC_URI="https://github.com/hartwork/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.2"
+
+distutils_enable_tests pytest