summaryrefslogtreecommitdiff
path: root/app-misc/screenfetch/screenfetch-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/screenfetch/screenfetch-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/screenfetch/screenfetch-9999.ebuild')
-rw-r--r--app-misc/screenfetch/screenfetch-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/screenfetch/screenfetch-9999.ebuild b/app-misc/screenfetch/screenfetch-9999.ebuild
new file mode 100644
index 000000000000..517954aa4689
--- /dev/null
+++ b/app-misc/screenfetch/screenfetch-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/f/F}"
+
+DESCRIPTION="Bash Screenshot Information Tool"
+HOMEPAGE="https://github.com/KittyKatt/screenFetch"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="curl X"
+
+DEPEND=""
+RDEPEND="
+ curl? ( net-misc/curl )
+ X? (
+ media-gfx/scrot
+ x11-apps/xdpyinfo
+ )"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/KittyKatt/screenFetch.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/KittyKatt/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+src_install() {
+ newbin ${PN}-dev ${PN}
+ einstalldocs
+}